summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2012-03-22 20:34:57 +0000
committerPádraig Brady <P@draigBrady.com>2012-03-22 20:34:57 +0000
commitb1428e3152afa3139a2968dd530e507ddd312051 (patch)
tree1a3a5fc9f062df5e29fb016401d4a46443ef7f13 /src/Makefile.am
parent049f1dbe6869a4918c9b2181b1014db6c0e3259b (diff)
downloadcoreutils-b1428e3152afa3139a2968dd530e507ddd312051.tar.xz
maint: refactor relpath() from `realpath` for use by `ln`
* src/relpath.c: Refactored from realpath.c and adjusted to support returning the relative path rather than just printing to stdout. * src/relpath.h: Export the relpath function. * src/Makefile.am: Reference the refactored relpath module. * po/POTFILES.in: Likewise. * src/realpath.c: Adjust to the refactored relpath module.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b12406477..85f12d65a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -477,6 +477,7 @@ ls_SOURCES = ls.c ls-ls.c
chown_SOURCES = chown.c chown-core.c
chgrp_SOURCES = chgrp.c chown-core.c
kill_SOURCES = kill.c operand2sig.c
+realpath_SOURCES = realpath.c relpath.c relpath.h
timeout_SOURCES = timeout.c operand2sig.c
mv_SOURCES = mv.c remove.c $(copy_sources)