summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2011-07-18 10:49:17 +0100
committerPádraig Brady <P@draigBrady.com>2011-07-25 12:00:26 +0100
commitaeb5222a6d7f7e9be5b737e2dbaf71185a9946db (patch)
tree662bc2fd206d7ff948efa26f255a7eea819d6e6c /src/Makefile.am
parent42c4ba6ceb638e3b624cbf03e0e0da44691f620c (diff)
downloadcoreutils-aeb5222a6d7f7e9be5b737e2dbaf71185a9946db.tar.xz
timeout: support sub-second timeouts
* src/timeout.c (settimeout): A new function to convert from a floating point duration and call alarm() or timer_settime() if that's available. (parse_duration): Return a double rather than unsigned int. (usage): Mention floating point is supported. (main): Pass the double to settimeout() rather than calling alarm() directly with the parsed int. (cleanup): Likewise. * doc/coreutils.texi (timeout invocation): Say floating point timeouts now supported, and mention the caveat with resolution. * bootstrap.conf: Include the timer-time gnulib module. * tests/misc/timeout-parameters: Add a test with nanoseconds. * NEWS: Mention the improvement.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ef0e7a4d3..b0b7eb527 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -329,6 +329,7 @@ date_LDADD += $(LIB_CLOCK_GETTIME)
ginstall_LDADD += $(LIB_CLOCK_GETTIME)
ls_LDADD += $(LIB_CLOCK_GETTIME)
pr_LDADD += $(LIB_CLOCK_GETTIME)
+timeout_LDADD += $(LIB_TIMER_TIME)
touch_LDADD += $(LIB_CLOCK_GETTIME)
# for gethrxtime