summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2004-09-13 13:05:08 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2004-09-13 13:05:08 +0000
commit7f924031d68d2d74127bf459249828673e20af0f (patch)
tree0a33606e9457920afd94c6dfe10ffaec65e8e913 /src/Makefile.am
parent16321b88eda41f0610df8063387081c2d35816b2 (diff)
downloadcoreutils-7f924031d68d2d74127bf459249828673e20af0f.tar.xz
(localedir.h): Don't redirect directly to target.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 111dde19d..9df6f5ed7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -162,9 +162,10 @@ localedir = $(datadir)/locale
BUILT_SOURCES = localedir.h
DISTCLEANFILES = localedir.h
localedir.h:
- @rm -f $@
- echo '#define LOCALEDIR "$(localedir)"' >$@
- @chmod a-w $@
+ @rm -f $@ $@-t
+ echo '#define LOCALEDIR "$(localedir)"' >$@-t
+ @chmod a-w $@-t
+ mv $@-t $@
BUILT_SOURCES += dircolors.h
dircolors.h: dcgen dircolors.hin