summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-08-15 06:53:02 +0000
committerJim Meyering <jim@meyering.net>2003-08-15 06:53:02 +0000
commit4f6b3338a1e43464f6ecb0e580878d52267f47f0 (patch)
treeef22613f4fb52255e0293e99efb32e214e6853f2 /src/Makefile.am
parenta38f52d85516c44c6d8d6ce243a2d9817c5cfebf (diff)
downloadcoreutils-4f6b3338a1e43464f6ecb0e580878d52267f47f0.tar.xz
(ASSORT): New var.
(check-README, ../AUTHORS): Use it.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 68a0ca6f5..0f949c79b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -211,6 +211,11 @@ all_programs = \
$(bin_SCRIPTS) \
$(EXTRA_PROGRAMS)
+# Sort in traditional ASCII order, regardless of the current locale;
+# otherwise we may get into trouble with distinct strings that the
+# current locale considers to be equal.
+ASSORT = LC_ALL=C sort
+
pm = progs-makefile
pr = progs-readme
# Ensure that the list of programs in README matches the list
@@ -220,7 +225,7 @@ check: check-README check-misc
check-README:
rm -rf $(pr) $(pm)
echo $(all_programs) \
- | tr -s ' ' '\n' | sort -u > $(pm)
+ | tr -s ' ' '\n' | $(ASSORT) -u > $(pm) && \
sed -n '/^The programs .* are:/,/^[a-zA-Z]/p' $(top_srcdir)/README \
| sed -n '/^ */s///p' | tr -s ' ' '\n' > $(pr)
diff $(pm) $(pr) && rm -rf $(pr) $(pm)
@@ -259,6 +264,6 @@ s2 = '/^\#define AUTHORS \\\\/{;n;$(sed_filter);p;q;}'
prog=`echo $$i|sed 's/\.c$$//'`; \
echo "$$prog: $$a"; \
fi; \
- done | sort -u ) > $@-t
+ done | $(ASSORT) -u ) > $@-t
chmod a-w $@-t
mv $@-t $@