summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-08-30 18:19:57 +0200
committerJim Meyering <meyering@redhat.com>2012-08-31 12:22:10 +0200
commit4adf4d2511ef3377b4071688c38542da913a4012 (patch)
treeed72afeed233b9551ae23b28f415041868f65d34 /src/Makefile.am
parent309988315697cb9647d33b3f2297a78cb5973f91 (diff)
downloadcoreutils-4adf4d2511ef3377b4071688c38542da913a4012.tar.xz
build: don't use '$<' in non-suffix rules
* src/Makefile.am (fs-def): Here: it's not portable to some non-GNU make implementations.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e681ccf39..9be3acfbc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -498,7 +498,7 @@ fs-magic-compare: fs-magic fs-kernel-magic fs-def
CLEANFILES += fs-def
fs-def: fs.h
- grep '^# *define ' $< | $(ASSORT) > $@-t && mv $@-t $@
+ grep '^# *define ' fs.h | $(ASSORT) > $@-t && mv $@-t $@
# Massage bits of the statfs man page and definitions from
# /usr/include/linux/magic.h to be in a form consistent with what's in fs.h.