summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-01-07 09:15:42 +0100
committerJim Meyering <jim@meyering.net>2007-03-29 21:37:05 +0200
commit4010e2d077e5031c464ead0f0ec0e664264d4107 (patch)
tree05e073b0a4024593adaa9b6b4c3a9cca9f38d585 /src/Makefile.am
parent8c94771b88fa5d595c21383ba83a1311f4ed3884 (diff)
downloadcoreutils-4010e2d077e5031c464ead0f0ec0e664264d4107.tar.xz
stat: Add support for SELinux in the form of a %C format directive.
* src/stat.c (follow_links): Make this variable file-global. (out_file_context): New function. (print_statfs): Honor %C. (print_stat): Honor %C. (do_stat): Remove follow_links parameter. (usage): Document the two %C directives. (main): Accept -Z (though it's a no-op). * src/Makefile.am (stat_LDADD): Define.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8d2580631..4bc4faefb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -112,6 +112,8 @@ cp_LDADD += $(LIB_ACL)
mv_LDADD += $(LIB_ACL)
ginstall_LDADD += $(LIB_ACL)
+stat_LDADD = $(LDADD) $(LIB_SELINUX)
+
$(PROGRAMS): ../lib/libcoreutils.a
SUFFIXES = .sh