summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2006-03-27 07:34:48 +0000
committerJim Meyering <jim@meyering.net>2006-03-27 07:34:48 +0000
commit20e2d352c0e1fb1e9cade09b758e95a3843b9b2c (patch)
tree1625711e603bbbde3436e521c06e97c4a81b4c4f /src/Makefile.am
parent1c952c4d7d71955656ff234694f529c555d8c65b (diff)
downloadcoreutils-20e2d352c0e1fb1e9cade09b758e95a3843b9b2c.tar.xz
(uptime_LDADD): Add $(POW_LIB), for uptime's use of strtod.
Tiny patch from Nickolai Zeldovich.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e31da576d..0fcb0832c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -98,7 +98,8 @@ nanosec_libs = $(LDADD) $(POW_LIB) $(LIB_NANOSLEEP)
sleep_LDADD = $(nanosec_libs)
tail_LDADD = $(nanosec_libs)
-uptime_LDADD = $(LDADD) $(GETLOADAVG_LIBS)
+# If necessary, add -lm to resolve use of pow in lib/strtod.c.
+uptime_LDADD = $(LDADD) $(POW_LIB) $(GETLOADAVG_LIBS)
su_LDADD = $(LDADD) $(LIB_CRYPT)