summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-01-04 14:55:42 +0100
committerJim Meyering <jim@meyering.net>2007-01-04 14:55:42 +0100
commitaa6a5547b387edef8db12345b97af9c35d9571df (patch)
tree4456f56e2bf34e8f295c25fe40e93a02b82fd6d0 /src/Makefile.am
parent2ed0544df45bb346e7960c0631dc8fe6803c132e (diff)
downloadcoreutils-aa6a5547b387edef8db12345b97af9c35d9571df.tar.xz
Ensure that "group --version" always prints the current year.
* src/groups.sh (version): Use @CURRENT_YEAR@, rather than 2006. * src/Makefile.am (.sh): Also substitute for @CURRENT_YEAR@. Suggestion from Eric Blake.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8c39ee02f..ddd13efd4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,6 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-
-## Copyright (C) 1990, 1991, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-## 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+## Copyright (C) 1990, 1991, 1993-2007 Free Software Foundation, Inc.
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -120,6 +119,7 @@ SUFFIXES = .sh
rm -f $@ $@-t
sed \
-e 's!@''bindir''@!$(bindir)!' \
+ -e 's/@''CURRENT_YEAR'@/`date +%Y`/ \
-e 's/@''GNU_PACKAGE''@/$(GNU_PACKAGE)/' \
-e 's/@''PACKAGE_BUGREPORT''@/$(PACKAGE_BUGREPORT)/' \
-e 's/@''VERSION''@/$(VERSION)/' $< > $@-t