summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2010-02-12 18:34:33 +0000
committerPádraig Brady <P@draigBrady.com>2010-02-16 15:19:40 +0000
commitcba49d57da12df9de9950d53ef31a1ff6341b9ab (patch)
treefe8298490332e9b92c7471d05ce1fd2ba8d53261 /man/Makefile.am
parenta2f81776adfc8d8ad39dd775648ee841aa352752 (diff)
downloadcoreutils-cba49d57da12df9de9950d53ef31a1ff6341b9ab.tar.xz
maint: fix the man page correlation tests
These checks were not being run as distcheck-hook targets are only supported in the top-level Makefile. Instead these tests are now run during a syntax-check. * cfg.mk (sc_man_file_correlation): A new syntax check to call the 2 existing tests to check the correlation between the programs and man/*.[1x]. * man/Makefile.am (sc_man_file_correlation): Call the 2 existing man page correlation tests. (check-x-vs-1): Remove the "GEN" annotation as it's a bit verbose. (check-programs-vs-x): Likewise. * src/Makefile.am (all_programs.list): Exclude libstdbuf.so from the list of programs. This issue was not noticed as the checks were not actually being run.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 7cebbf143..c3c38039a 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -180,7 +180,8 @@ sc_option_desc_uppercase: $(dist_man1_MANS) $(NO_INSTALL_PROGS_DEFAULT:%=%.1)
{ echo 1>&2 '$(ME): found initial capitals in --help'; \
exit 1; } || :;
-distcheck-hook: check-x-vs-1 check-programs-vs-x
+.PHONY: sc_man_file_correlation
+sc_man_file_correlation: check-x-vs-1 check-programs-vs-x
# Sort in traditional ASCII order, regardless of the current locale;
# otherwise we may get into trouble with distinct strings that the
@@ -193,7 +194,7 @@ ASSORT = LC_ALL=C sort
# add them here manually.
.PHONY: check-x-vs-1
check-x-vs-1:
- $(AM_V_GEN)PATH=../src$(PATH_SEPARATOR)$$PATH; export PATH; \
+ @PATH=../src$(PATH_SEPARATOR)$$PATH; export PATH; \
t=$@-t; \
(cd $(srcdir) && ls -1 *.x) | sed 's/\.x$$//' | $(ASSORT) > $$t;\
(echo $(dist_man1_MANS) $(NO_INSTALL_PROGS_DEFAULT) \
@@ -207,7 +208,7 @@ all_programs = \
.PHONY: check-programs-vs-x
check-programs-vs-x:
- $(AM_V_GEN)status=0; \
+ @status=0; \
for p in dummy `$(all_programs)`; do \
test $$p = dummy && continue; \
test $$p = ginstall && p=install || : ; \