summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-01-28 15:16:17 +0100
committerJim Meyering <meyering@redhat.com>2008-01-29 09:40:31 +0100
commita7f5e64909fa24ecf2ef72a8cc3070cf38332842 (patch)
tree3f973f5ca4f7e65706c2d1ffcf09231c3e024e71 /man/Makefile.am
parent533391a2a75f49da27adc71214caeeb4ef07d81c (diff)
downloadcoreutils-a7f5e64909fa24ecf2ef72a8cc3070cf38332842.tar.xz
Avoid "make distcheck" failure: newly-created man/*.1 files not removed
* Makefile.am (EXTRA_DIST): Add .version. (.version): New rule. (dist-hook): Don't create $(distdir)/.version here, now that it's being distributed. * man/Makefile.am (common_dep): Use ../.version, not ../VERSION. (../VERSION): Remove rule. * GNUmakefile (dummy): Create .version, not VERSION. Add an extra "...:= $(shell..." statement to ensure that .version exists even when the preceding code is not run. * .gitignore: Remove both .version and VERSION. Signed-off-by: Jim Meyering <meyering@redhat.com>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 6cad1a44e..a4351d651 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -22,8 +22,8 @@ man_aux = $(dist_man_MANS:.1=.x)
EXTRA_DIST = $(man_aux) $(NO_INSTALL_PROGS_DEFAULT:%=%.x) help2man
MAINTAINERCLEANFILES = $(dist_man_MANS)
-# Depend on ../VERSION to get version number changes.
-common_dep = ../VERSION
+# Depend on ../.version to get version number changes.
+common_dep = ../.version
# Note that arch depends on uname.c
arch.1: $(common_dep) $(srcdir)/arch.x ../src/uname.c
@@ -198,6 +198,3 @@ check-programs-vs-x:
|| { echo missing $$p.x 1>&2; status=1; }; \
done; \
exit $$status
-
-../VERSION:
- echo $(VERSION) > $@-t && mv $@-t $@