summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-09-08 09:17:32 +0000
committerJim Meyering <jim@meyering.net>2003-09-08 09:17:32 +0000
commita1e0d54e2d5ab766620830676f3c7a9ca16c6266 (patch)
treeb1fa52a64ed394589f1fd6f0f3e82bfd94d57e01 /man/Makefile.am
parenta1dfc8dc22dae9e789d998be68092102f0601663 (diff)
downloadcoreutils-a1e0d54e2d5ab766620830676f3c7a9ca16c6266.tar.xz
(programs): Use ../src, not $(srcdir)/../src.
(check-programs-vs-x): Fail if $(programs) is empty.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index c719dfc75..26f0d7b29 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -155,11 +155,12 @@ check-x-vs-1:
programs = \
echo 'spy:;@echo $$(all_programs)' \
- | MAKEFLAGS= $(MAKE) -s -C $(srcdir)/../src -f Makefile -f - spy \
+ | MAKEFLAGS= $(MAKE) -s -C ../src -f Makefile -f - spy \
| fmt -1 | $(ASSORT) -u | grep -v '\['
.PHONY: check-programs-vs-x
check-programs-vs-x:
+ test "$(programs)" && : || exit 1
for p in `$(programs)`; do \
test $$p = ginstall && p=install || : ; \
test -f $(srcdir)/$$p.x \