summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-09-10 09:26:56 +0000
committerJim Meyering <jim@meyering.net>2003-09-10 09:26:56 +0000
commit8e9121a740ccd2febf8fbe5144f869b4d452e445 (patch)
treebdc7b11c361f130d82bdb6ef217034e0165f0af8 /man/Makefile.am
parent8bf64609dc62915ad4e3a6348e9ac847140dca80 (diff)
downloadcoreutils-8e9121a740ccd2febf8fbe5144f869b4d452e445.tar.xz
(programs, check-x-vs-1): Use ../src/tr -s ' ' '\n' in place
of `fmt -1'. Using the just-built tr is a little cleaner. Christian Krackowizer reported that HPUX 10.20 doesn't have fmt.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 26f0d7b29..a367c3ddc 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -149,14 +149,14 @@ check-x-vs-1:
PATH=../src$(PATH_SEPARATOR)$$PATH; export PATH; \
t=ls-files.$$$$; \
(cd $(srcdir) && ls -1 *.x) | sed 's/\.x$$//' | $(ASSORT) > $$t;\
- echo $(dist_man_MANS) | fmt -w1 | sed 's/\.1$$//' | $(ASSORT) \
- | diff - $$t || { rm $$t; exit 1; }; \
+ echo $(dist_man_MANS) | tr -s ' ' '\n' | sed 's/\.1$$//' \
+ | $(ASSORT) | diff - $$t || { rm $$t; exit 1; }; \
rm $$t
programs = \
echo 'spy:;@echo $$(all_programs)' \
| MAKEFLAGS= $(MAKE) -s -C ../src -f Makefile -f - spy \
- | fmt -1 | $(ASSORT) -u | grep -v '\['
+ | ../src/tr -s ' ' '\n' | $(ASSORT) -u | grep -v '\['
.PHONY: check-programs-vs-x
check-programs-vs-x: