summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2008-03-28 11:05:55 +0000
committerJim Meyering <meyering@redhat.com>2008-06-02 14:40:26 +0200
commit265c4b83a81c643f3359be926ef8034f28f321ed (patch)
tree4e8cf6f6938638e99f1e0d848780029480e28216 /man/Makefile.am
parent4a510cd3997325cd8617c0ae082c9eb7220208d6 (diff)
downloadcoreutils-265c4b83a81c643f3359be926ef8034f28f321ed.tar.xz
new program: timeout
* AUTHORS: Register as the author. * NEWS: Mention this change. * README: Add timeout command to list. * src/timeout.c: New file. * src/kill.c (operand2sig): Move function to its own file, now that timeout.c will also use it. * src/operand2sig.c (operand2sig): New file, extracted from kill.c. * src/operand2sig.h (operand2sig): Declare. * src/Makefile.am (EXTRA_PROGRAMS): Add timeout. * src/.gitignore: Add timeout binary to list to ignore. * doc/coreutils.texi (timeout invocation): Add timeout info. (Signal specifications): New section, also referenced by kill. * man/Makefile.am (timeout.1): Add dependency. * man/timeout.x: New file. * po/POTFILES.in: Add timeout.c and operand2sig.c to list to translate. * tests/Makefile.am (TESTS): Add the two new tests. * tests/misc/help-version: Add support for new timeout command. * tests/misc/invalid-opt: Add support for new timeout command. * tests/misc/timeout: New file: check basic timeout operation. * tests/misc/timeout-parameters: New file: check invalid parameter combinations.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 7164b3b23..3fa22609c 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -113,6 +113,7 @@ tac.1: $(common_dep) $(srcdir)/tac.x ../src/tac.c
tail.1: $(common_dep) $(srcdir)/tail.x ../src/tail.c
tee.1: $(common_dep) $(srcdir)/tee.x ../src/tee.c
test.1: $(common_dep) $(srcdir)/test.x ../src/test.c
+timeout.1: $(common_dep) $(srcdir)/timeout.x ../src/timeout.c
touch.1: $(common_dep) $(srcdir)/touch.x ../src/touch.c
tr.1: $(common_dep) $(srcdir)/tr.x ../src/tr.c
true.1: $(common_dep) $(srcdir)/true.x ../src/true.c