summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2008-01-25 16:05:52 +0000
committerJim Meyering <meyering@redhat.com>2008-02-13 14:37:22 +0100
commit167b8025aca487de001da2448c1aebc2747bc1d3 (patch)
tree8c0317373fe16fedf407e468d79d914c860e3ece /man/Makefile.am
parent0601086bd8bc923e9a3eb91201428e2a30b43852 (diff)
downloadcoreutils-167b8025aca487de001da2448c1aebc2747bc1d3.tar.xz
Replace groups.sh with groups.c.
* src/groups.c (main): New file, replacing groups.sh. * src/group-list.c, src/group-list.h: New files, factored out of id.c, implementing the functionality that "id" and "groups" have in common. * src/id.c (print_full_info): Avoid a segfault when trying to print an error message if getgroups fails. (print_group_list): Move to group-list.c. (print_group): Likewise. * man/Makefile.am: When building groups.1, obtain the help text from src/groups.c, not src/groups.sh. (noinst_HEADERS): Add group-list.h. (group): Remove rule. (dist_man_MANS): Remove groups.1. * doc/coreutils.texi (groups: Print group names a user is in): Explain why "groups" and "groups $(id -un)" give different results in existing login sessions after you change the group database. (id: Print user identity): Likewise for "id". * po/POTFILES.in: Add src/group-list.c and src/groups.c. * NEWS: mention this. * AUTHORS: Update.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index a4351d651..9076afcb0 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -15,7 +15,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-dist_man_MANS = groups.1 $(MAN)
+dist_man_MANS = $(MAN)
man_aux = $(dist_man_MANS:.1=.x)
@@ -59,7 +59,7 @@ factor.1: $(common_dep) $(srcdir)/factor.x ../src/factor.c
false.1: $(common_dep) $(srcdir)/false.x ../src/false.c
fmt.1: $(common_dep) $(srcdir)/fmt.x ../src/fmt.c
fold.1: $(common_dep) $(srcdir)/fold.x ../src/fold.c
-groups.1: $(common_dep) $(srcdir)/groups.x ../src/groups.sh
+groups.1: $(common_dep) $(srcdir)/groups.x ../src/groups.c
head.1: $(common_dep) $(srcdir)/head.x ../src/head.c
hostid.1: $(common_dep) $(srcdir)/hostid.x ../src/hostid.c
hostname.1: $(common_dep) $(srcdir)/hostname.x ../src/hostname.c