summaryrefslogtreecommitdiff
path: root/m4/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2001-07-15 14:33:50 +0000
committerJim Meyering <jim@meyering.net>2001-07-15 14:33:50 +0000
commitd010bd778c5440148acfe82949d3cd18d4cffda2 (patch)
tree2abb93e7a3406669e6885cc0a3bd5003ee9af0c7 /m4/Makefile.am
parent264546ddf19cc94bdda3e877b57afe74067ed994 (diff)
downloadcoreutils-d010bd778c5440148acfe82949d3cd18d4cffda2.tar.xz
.
Diffstat (limited to 'm4/Makefile.am')
-rw-r--r--m4/Makefile.am45
1 files changed, 6 insertions, 39 deletions
diff --git a/m4/Makefile.am b/m4/Makefile.am
index 7b6e0d574..8d8f06d28 100644
--- a/m4/Makefile.am
+++ b/m4/Makefile.am
@@ -1,7 +1,8 @@
## Process this file with automake to produce Makefile.in -*-Makefile-*-
##m4-files-begin
-EXTRA_DIST = README jm-glibc-io.m4n Makefile.am.in \
+EXTRA_DIST = \
+ README jm-glibc-io.m4 jm-glibc-io.m4n Makefile.am.in \
afs.m4 \
assert.m4 \
bison.m4 \
@@ -21,6 +22,7 @@ ftruncate.m4 \
getgroups.m4 \
getline.m4 \
getloadavg.m4 \
+gettimeofday.m4 \
glibc.m4 \
glibc21.m4 \
gnu-source.m4 \
@@ -75,47 +77,12 @@ xstrtoumax.m4
Makefile.am: Makefile.am.in
rm -f $@ $@t
sed -n '1,/^##m4-files-begin/p' $< > $@t
- ((echo EXTRA_DIST = README jm-glibc-io.m4n Makefile.am.in|tr '\012' @);\
+ (((echo EXTRA_DIST =; \
+ echo " README jm-glibc-io.m4 jm-glibc-io.m4n Makefile.am.in" \
+ ) | tr '\012' @); \
(echo *.m4|tr ' ' @) ) \
|sed 's/@$$/%/;s/@/ \\@/g' |tr @% '\012\012' \
>> $@t
sed -n '/^##m4-files-end/,$$p' $< >> $@t
- echo >> $@t
- echo all-local: jm-glibc-io.m4 >> $@t
chmod a-w $@t
mv $@t $@
-
-unlocked_functions = \
- clearerr_unlocked feof_unlocked ferror_unlocked \
- fflush_unlocked fgets_unlocked fputc_unlocked fputs_unlocked \
- fread_unlocked fwrite_unlocked getc_unlocked getchar_unlocked \
- putc_unlocked putchar_unlocked
-
-comma_separated = $(shell echo $(unlocked_functions)|tr -s ' ' ,)
-base_functions = $(patsubst %_unlocked,%,$(unlocked_functions))
-jm-glibc-io.m4: jm-glibc-io.m4n Makefile
- echo 'dnl This file is automatically generated from $<' > $@t
- echo '' >> $@t
- sed \
- -e 's/@space_separated@/$(unlocked_functions)/g' \
- -e 's/@comma_separated@/$(comma_separated)/g' \
- $< >> $@t
- move-if-change $@t $@
-
-unlocked-io.h: unlocked-io.hin Makefile.am.in
- tmp=t$$$$; \
- echo '' > $$tmp; \
- for f in $(base_functions); do \
- u=`echo $$f|tr '[:lower:]' '[:upper:]'`; \
- echo "# if HAVE_$${u}_UNLOCKED" >> $$tmp; \
- echo "# undef $$f" >> $$tmp; \
- echo "# define $$f(S) $${f}_unlocked (S)" >> $$tmp; \
- echo '#endif' >> $$tmp; \
- done; \
- sed "/^@replace_this@$$/r$$tmp" $< \
- | sed "/^@replace_this@$$/d" \
- $< > $@t; \
- rm -f $$tmp; \
- mv $@t $@
-
-all-local: jm-glibc-io.m4