summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-08-18 07:51:29 +0000
committerJim Meyering <jim@meyering.net>2003-08-18 07:51:29 +0000
commitd81acc082690dc860945a4ff1f17de886097bd36 (patch)
treea22c76fcffaf07b8fe33a18004f7ffe8deb80bd0 /lib/Makefile.am
parent0fc380c89d65822d8f72f4946269e77e92ece67b (diff)
downloadcoreutils-d81acc082690dc860945a4ff1f17de886097bd36.tar.xz
Merge from gnulib.
(libfetish_a_SOURCES): Remove getndelim2.c, getndelim2.h, xstrtoimax.c. Add localcharset.h. (CLEANFILES, SUFFIXES): Initialize to empty. (EXTRA_DIST): Add getndelim2.c, getndelim2.h. (install-exec-local): Use $(GLIBC21), not @GLIBC21@. Do not mkdir libdir if not glibc21. (charset.alias): @host@ -> $(host). (SUFFIXES, .sin.sed, CLEANFILES): Reorder rules to match gnulib module suggestions.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am28
1 files changed, 15 insertions, 13 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index e61123dfe..a48f680f1 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -61,7 +61,6 @@ libfetish_a_SOURCES = \
ftw_.h \
full-read.c full-read.h \
full-write.c full-write.h \
- getndelim2.c getndelim2.h \
getline.h \
getpagesize.h \
gettime.c \
@@ -75,7 +74,7 @@ libfetish_a_SOURCES = \
imaxtostr.c \
lchown.h \
linebuffer.c linebuffer.h \
- localcharset.c \
+ localcharset.c localcharset.h \
long-options.c long-options.h \
makepath.c makepath.h \
mbswidth.c mbswidth.h \
@@ -125,7 +124,6 @@ libfetish_a_SOURCES = \
xstrtod.c xstrtod.h \
xstrtol.c xstrtol.h \
xstrtoul.c \
- xstrtoimax.c \
xstrtoumax.c \
yesno.c
@@ -142,13 +140,16 @@ lib_OBJECTS = $(libfetish_a_OBJECTS)
BUILT_SOURCES = getdate.c
+CLEANFILES =
MAINTAINERCLEANFILES = $(BUILT_SOURCES)
MOSTLYCLEANFILES =
+SUFFIXES =
EXTRA_DIST = config.charset ref-add.sin ref-del.sin \
+ getndelim2.c getndelim2.h \
inttostr.c inttostr.h
-# The following is needed in order to install a simple file in $(libdir)
+# We need the following in order to install a simple file in $(libdir)
# which is shared with other installed packages. We use a list of referencing
# packages so that "make uninstall" will remove the file if and only if it
# is not used by another installed package.
@@ -160,13 +161,13 @@ all-local: charset.alias ref-add.sed ref-del.sed
charset_alias = $(DESTDIR)$(libdir)/charset.alias
charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
install-exec-local: all-local
- $(mkinstalldirs) $(DESTDIR)$(libdir)
+ test $(GLIBC21) != no || $(mkinstalldirs) $(DESTDIR)$(libdir)
if test -f $(charset_alias); then \
sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
$(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
rm -f $(charset_tmp) ; \
else \
- if test @GLIBC21@ = no; then \
+ if test $(GLIBC21) = no; then \
sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
$(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
rm -f $(charset_tmp) ; \
@@ -186,9 +187,16 @@ uninstall-local: all-local
fi
charset.alias: config.charset
- $(SHELL) $(srcdir)/config.charset '@host@' > t-$@
+ $(SHELL) $(srcdir)/config.charset '$(host)' > t-$@
+ mv t-$@ $@
+
+SUFFIXES += .sed .sin
+.sin.sed:
+ sed -e '/^#/d' -e 's/@''PACKAGE''@/$(PACKAGE)/g' $< > t-$@
mv t-$@ $@
+CLEANFILES += charset.alias ref-add.sed ref-del.sed
+
BUILT_SOURCES += $(STDBOOL_H)
EXTRA_DIST += stdbool_.h
MOSTLYCLEANFILES += stdbool.h stdbool.ht
@@ -219,10 +227,4 @@ fnmatch.h: fnmatch_.h
mv $@-t $@
MOSTLYCLEANFILES += fnmatch.h fnmatch.h-t
-SUFFIXES = .sed .sin
-.sin.sed:
- sed -e '/^#/d' -e 's/@''PACKAGE''@/$(PACKAGE)/g' $< > t-$@
- mv t-$@ $@
-
-CLEANFILES = charset.alias ref-add.sed ref-del.sed
DISTCLEANFILES = ftw.h search.h