summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-04-05 16:52:48 +0000
committerJim Meyering <jim@meyering.net>2003-04-05 16:52:48 +0000
commitc573813515947b3b91736300c6d59f1817f4b646 (patch)
tree37c73b3b0f0a4cf5a0c950e03706c8f6bd938866 /lib/Makefile.am
parentdd72f39b52510f8e0ac10e84985b1b1ec10b673d (diff)
downloadcoreutils-c573813515947b3b91736300c6d59f1817f4b646.tar.xz
(DEFS): Use += notation rather than `DEFS = ... @DEFS@'.
Use $(VAR) rather than @VAR@, now that we can rely on automake to emit a definition for each substituted variable.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index b27dd26c2..205914a1d 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -21,7 +21,7 @@
noinst_LIBRARIES = libfetish.a
INCLUDES = -I.. -I$(srcdir)
-DEFS = -DLIBDIR=\"$(libdir)\" @DEFS@
+DEFS += -DLIBDIR=\"$(libdir)\"
## Put relatively complex files at the beginning of the list so
## that parallel compiles finish a tiny bit sooner. I don't see
@@ -129,7 +129,7 @@ libfetish_a_SOURCES = \
xstrtoumax.c \
yesno.c
-libfetish_a_LIBADD = @LIBOBJS@ @ALLOCA@
+libfetish_a_LIBADD = $(LIBOBJS) $(ALLOCA)
libfetish_a_DEPENDENCIES = $(libfetish_a_LIBADD)
@@ -182,7 +182,7 @@ charset.alias: config.charset
SUFFIXES = .sed .sin
.sin.sed:
- sed -e '/^#/d' -e 's/@''PACKAGE''@/@PACKAGE@/g' $< > t-$@
+ sed -e '/^#/d' -e 's/@''PACKAGE''@/$(PACKAGE)/g' $< > t-$@
mv t-$@ $@
CLEANFILES = charset.alias ref-add.sed ref-del.sed