summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2004-08-20 02:10:15 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2004-08-20 02:10:15 +0000
commit529a7c21fd1950e3a1e5a4ec429b6e2c12f619d8 (patch)
tree9a4e62d84b9123b7ed14fbe3f071e1d5436e6487 /lib/Makefile.am
parent463f2060b7f399676d25a598aa4ec45ec8e3cb07 (diff)
downloadcoreutils-529a7c21fd1950e3a1e5a4ec429b6e2c12f619d8.tar.xz
Sync getopt from gnulib.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 386194c65..e5a776b72 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -33,7 +33,6 @@ libfetish_a_SOURCES = \
posixtm.c posixtm.h \
posixver.c posixver.h \
strftime.c strftime.h \
- getopt.c getopt.h getopt1.c getopt_int.h \
hash.c hash.h \
hash-pjw.c hash-pjw.h \
__fpending.h \
@@ -239,3 +238,14 @@ fnmatch.h: fnmatch_.h
cp $(srcdir)/fnmatch_.h $@-t
mv $@-t $@
MOSTLYCLEANFILES += fnmatch.h fnmatch.h-t
+
+BUILT_SOURCES += $(GETOPT_H)
+EXTRA_DIST += getopt_.h getopt_int.h
+
+# We need the following in order to create an <getopt.h> when the system
+# doesn't have one that works with the given compiler.
+all-local $(lib_OBJECTS): $(GETOPT_H)
+getopt.h: getopt_.h
+ cp $(srcdir)/getopt_.h $@-t
+ mv $@-t $@
+MOSTLYCLEANFILES += getopt.h getopt.h-t