summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2003-06-02 08:15:38 +0000
committerJim Meyering <jim@meyering.net>2003-06-02 08:15:38 +0000
commit1f9186195f594321bd8e74ede17d402af2669628 (patch)
tree65ffbfbdb9292a15d90569c3a511db6d684862a6 /lib/Makefile.am
parent5594c4570e3b2123270518837098a9c6877f93f7 (diff)
downloadcoreutils-1f9186195f594321bd8e74ede17d402af2669628.tar.xz
(MOSTLYCLEANFILES): Initialize.
(stdbool.h): New rule. (all-local $(lib_OBJECTS)): Depend on $(STDBOOL_H) (MOSTLYCLEANFILES): Add stdbool.h. (EXTRA_DIST): Add stdbool.h.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 205914a1d..ffee8cf03 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -135,6 +135,7 @@ libfetish_a_DEPENDENCIES = $(libfetish_a_LIBADD)
BUILT_SOURCES = getdate.c
MAINTAINERCLEANFILES = $(BUILT_SOURCES)
+MOSTLYCLEANFILES =
EXTRA_DIST = config.charset ref-add.sin ref-del.sin \
fnmatch_loop.c inttostr.c inttostr.h
@@ -180,6 +181,14 @@ charset.alias: config.charset
$(SHELL) $(srcdir)/config.charset '@host@' > t-$@
mv t-$@ $@
+# Create stdbool.h on systems that lack a working one.
+all-local $(lib_OBJECTS): $(STDBOOL_H)
+stdbool.h: stdbool.hin
+ sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' $(srcdir)/stdbool.hin > t-$@
+ mv t-$@ $@
+MOSTLYCLEANFILES += stdbool.h
+EXTRA_DIST += stdbool.hin
+
SUFFIXES = .sed .sin
.sin.sed:
sed -e '/^#/d' -e 's/@''PACKAGE''@/$(PACKAGE)/g' $< > t-$@