summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2000-06-03 08:34:34 +0000
committerJim Meyering <jim@meyering.net>2000-06-03 08:34:34 +0000
commit1b306b070e64291ec9a1a2a8110db5b458e41f5f (patch)
treeb408c8343847c3a9c1cc48244df3008ba66185ec /lib/Makefile.am
parent70ac95bbb2a5bbf174fe641892dad446f8719347 (diff)
downloadcoreutils-1b306b070e64291ec9a1a2a8110db5b458e41f5f.tar.xz
(install-exec-local): On systems with glibc-2.1 or
newer, don't install charset.alias.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 73a7cb5a8..a84992521 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -59,6 +59,8 @@ stat.c: xstat.in
# which is shared with other installed packages. We use a list of referencing
# packages so that "make uninstall" will remove the file if and only if it
# is not used by another installed package.
+# On systems with glibc-2.1 or newer, the file is redundant, therefore we
+# avoid installing it.
all-local: charset.alias ref-add.sed ref-del.sed
@@ -66,12 +68,17 @@ charset_alias = $(DESTDIR)$(libdir)/charset.alias
charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
install-exec-local: all-local
$(mkinstalldirs) $(DESTDIR)$(libdir)
- test -f $(charset_alias) \
- && orig=$(charset_alias) \
- || orig=charset.alias; \
- sed -f ref-add.sed $$orig > $(charset_tmp)
- $(INSTALL_DATA) $(charset_tmp) $(charset_alias)
- rm -f $(charset_tmp)
+ if test -f $(charset_alias); then \
+ sed -f ref-add.sed $(charset_alias) > $(charset_tmp) ; \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
+ else \
+ if test @GLIBC21@ = no; then \
+ sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
+ fi ; \
+ fi
uninstall-local: all-local
if test -f $(charset_alias); then \