summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2005-12-14 00:08:54 +0000
committerPaul Eggert <eggert@cs.ucla.edu>2005-12-14 00:08:54 +0000
commita6caba2509b98248f11844186ef05fc844226c83 (patch)
tree9d0a34115e1405fc1a59de6da3213b7050a3a8e9 /lib/Makefile.am
parent706c4369de2b859125b1b86370c374809fdde4d3 (diff)
downloadcoreutils-a6caba2509b98248f11844186ef05fc844226c83.tar.xz
(stdbool.h): Resurrect the 'sed' that goes along with '#if !@HAVE_BOOL@".
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index ab6fd1bea..a66a6c1d0 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -126,7 +126,7 @@ EXTRA_DIST += stdbool_.h
MOSTLYCLEANFILES += stdbool.h stdbool.h-t
# Create stdbool.h on systems that lack a working one.
stdbool.h: stdbool_.h
- cp $(srcdir)/stdbool_.h $@-t
+ sed -e 's/@''HAVE__BOOL''@/$(HAVE__BOOL)/g' < $(srcdir)/stdbool_.h > $@-t
mv $@-t $@
BUILT_SOURCES += $(ALLOCA_H)