summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2012-09-09 08:21:16 +0200
committerJim Meyering <meyering@redhat.com>2012-09-11 11:23:17 +0200
commit8a0e1bce040f982b27cd715a253d6c83bf806dbe (patch)
treedf71e707f1accd01f745a89860276e0142b7af04 /lib/Makefile.am
parentada994274cacac427e7a2004e7bd6c16e7f140a7 (diff)
downloadcoreutils-8a0e1bce040f982b27cd715a253d6c83bf806dbe.tar.xz
build: build lib/ using non-recursive make
* bootstrap.conf (gnulib_modules): Use the new module. (bootstrap_post_import_hook): Invoke prefix-gnulib-mk. * configure.ac (AC_CONFIG_FILES): Remove lib/Makefile. * lib/Makefile.am: Renamed... * lib/local.mk: ...to this. * src/local.mk (CLEANFILES): Append, don't set. (noinst_LIBRARIES): Likewise. (AM_CPPFLAGS): Don't set this here. * Makefile.am (AM_CPPFLAGS): Define here instead. (noinst_LIBRARIES, CLEANFILES, MOSTLYCLEANDIRS, MOSTLYCLEANFILES): Initialize here, so we can append to them from each included local.mk (SUBDIRS): Remove "lib".
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
deleted file mode 100644
index 885f9b2dc..000000000
--- a/lib/Makefile.am
+++ /dev/null
@@ -1,37 +0,0 @@
-## Makefile for gnulib/lib -*-Makefile-*-
-
-# Copyright (C) 1995-2012 Free Software Foundation, Inc.
-
-## This program is free software: you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation, either version 3 of the License, or
-## (at your option) any later version.
-##
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-## GNU General Public License for more details.
-##
-## You should have received a copy of the GNU General Public License
-## along with this program. If not, see <http://www.gnu.org/licenses/>.
-
-AM_CFLAGS =
-AM_CPPFLAGS =
-BUILT_SOURCES =
-CLEANFILES =
-EXTRA_DIST =
-MAINTAINERCLEANFILES =
-MOSTLYCLEANDIRS =
-MOSTLYCLEANFILES =
-SUFFIXES =
-noinst_LIBRARIES =
-
-include gnulib.mk
-
-AM_CFLAGS += $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)
-
-libcoreutils_a_SOURCES += \
- buffer-lcm.c buffer-lcm.h
-
-libcoreutils_a_LIBADD += $(LIBOBJS)
-libcoreutils_a_DEPENDENCIES += $(LIBOBJS)