summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-09-06 09:48:46 +0200
committerJim Meyering <meyering@redhat.com>2011-11-24 22:18:29 +0100
commit3e26551096823b744016f616a34c1992e35cd68d (patch)
tree7d515e8541dded9549d1e334f1cd34228c0dc78c /lib/Makefile.am
parent5bf2c0eed323dc0079e4388a1d8da03eae29155a (diff)
downloadcoreutils-3e26551096823b744016f616a34c1992e35cd68d.tar.xz
maint: bootstrap: run autopoint and libtoolize *before* gnulib-tool
* bootstrap (AUTOPOINT, AUTORECONF): Factor out definitions. Run autopoint and libtoolize *before* gnulib-tool. After it, run an abbreviated autoreconf, rather than a loop around all tools. * bootstrap.conf (gnulib_tool_option_extras): Add both --symlink and --makefile-name=gnulib.mk. Remove stray use of $bt. * lib/Makefile.am: Initialize all of the following so that generated code in gnulib.mk may use += to append to those variables: AM_CFLAGS, AM_CPPFLAGS, BUILT_SOURCES, CLEANFILES, EXTRA_DIST, MAINTAINERCLEANFILES, MOSTLYCLEANDIRS, MOSTLYCLEANFILES, SUFFIXES, noinst_LIBRARIES.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 0759b0d0d..b73cc8b16 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -15,6 +15,17 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
+AM_CFLAGS =
+AM_CPPFLAGS =
+BUILT_SOURCES =
+CLEANFILES =
+EXTRA_DIST =
+MAINTAINERCLEANFILES =
+MOSTLYCLEANDIRS =
+MOSTLYCLEANFILES =
+SUFFIXES =
+noinst_LIBRARIES =
+
include gnulib.mk
AM_CFLAGS += $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)