summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2007-07-22 18:26:23 +0200
committerJim Meyering <jim@meyering.net>2007-07-22 19:26:22 +0200
commitcd098ea1997e42e1dfe9633eac2fbee4c545aaf1 (patch)
treee740949a4908de4fd51bc85c21beaae379845904 /configure.ac
parenta0c8d0e0fe514c0c9b37ced9b4f96d3e076de44b (diff)
downloadcoreutils-cd098ea1997e42e1dfe9633eac2fbee4c545aaf1.tar.xz
Arrange to rerun configure whenever src/Makefile.am changes.
* configure.ac: Arrange to rerun configure whenever src/Makefile.am changes. That file contains the list of program names that must be substituted into files like man/Makefile. Add quotes around AC_SUBST arguments. Signed-off-by: Jim Meyering <jim@meyering.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6b5cba4af..081dbda0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -313,9 +313,14 @@ MAN=`echo "$MAN"|sed 's/\<ginstall\.1\>/install.1/'`
MAN=`echo "$MAN"|sed 's/\@<:@\.1//'`
OPTIONAL_BIN_PROGS=`echo "$optional_bin_progs "|sed 's/ /\$(EXEEXT) /g;s/ $//'`
-AC_SUBST(OPTIONAL_BIN_PROGS)
+AC_SUBST([OPTIONAL_BIN_PROGS])
NO_INSTALL_PROGS_DEFAULT=$no_install_progs_default
-AC_SUBST(NO_INSTALL_PROGS_DEFAULT)
+AC_SUBST([NO_INSTALL_PROGS_DEFAULT])
+
+# Arrange to rerun configure whenever the file, src/Makefile.am,
+# containing the list of program names changes.
+CONFIG_STATUS_DEPENDENCIES='$(top_srcdir)/src/Makefile.am'
+AC_SUBST([CONFIG_STATUS_DEPENDENCIES])
############################################################################
AM_GNU_GETTEXT([external], [need-formatstring-macros])