summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-09-11 23:35:31 +0200
committerJim Meyering <meyering@redhat.com>2012-09-12 20:52:18 +0200
commit8d4924f10792cd443efafe8405f70a75d66cd9d5 (patch)
treeb2ad1ec491c5a63a6efd391f8ee9bd04051e0e9a /configure.ac
parenta11cba5372f4f850309512aa70a3a9118a11201c (diff)
downloadcoreutils-8d4924f10792cd443efafe8405f70a75d66cd9d5.tar.xz
build: fixup: correctly recognize if perl is missing
* configure.ac: Here, by adding a missing '*' to the wildcard in a 'case' construct over the contents of $PERL. Introduced in commit v8.19-41-g00f5ba1.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 713a9b986..e5e05be5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ coreutils_MACROS
# FIXME: this is suboptimal. Ideally, we would be able to call gl_PERL
# with an ACTION-IF-NOT-FOUND argument ...
cu_have_perl=yes
-case $PERL in *"/missing ") cu_have_perl=no;; esac
+case $PERL in *"/missing "*) cu_have_perl=no;; esac
AM_CONDITIONAL([HAVE_PERL], [test $cu_have_perl = yes])
AC_ARG_ENABLE([gcc-warnings],