summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2007-08-30 17:11:59 +0200
committerJim Meyering <jim@meyering.net>2007-08-30 17:12:56 +0200
commit4b11f24c64db5fc05acc4dd87c8733d3f6be1265 (patch)
treebb9006d0ac7aa0b787a2722f96ce95d935ff3c90 /configure.ac
parent58ddd2c5a1a80b1c3ef6d1717842d082d24409cf (diff)
downloadcoreutils-4b11f24c64db5fc05acc4dd87c8733d3f6be1265.tar.xz
Use PACKAGE_NAME instead of GNU_PACKAGE.
* src/Makefile.am (.sh, uninstall-local): Adjust all users of hand-rolled GNU_PACKAGE to instead use autoconf-provided PACKAGE_NAME. * src/basename.c (main): Likewise. * src/chroot.c (main): Likewise. * src/dirname.c (main): Likewise. * src/echo.c (main): Likewise. * src/expr.c (main): Likewise. * src/factor.c (main): Likewise. * src/groups.sh (version): Likewise. Also, reflect change in --version output due to GPLv3. * src/hostid.c (main): Likewise. * src/hostname.c (main): Likewise. * src/link.c (main): Likewise. * src/logname.c (main): Likewise. * src/nice.c (main): Likewise. * src/nohup.c (main): Likewise. * src/printenv.c (main): Likewise. * src/printf.c (main): Likewise. * src/pwd.c (main): Likewise. * src/setuidgid.c (main): Likewise. * src/sleep.c (main): Likewise. * src/system.h (case_GETOPT_VERSION_CHAR): Likewise. * src/test.c (main): Likewise. * src/true.c (main): Likewise. * src/unlink.c (main): Likewise. * src/uptime.c (main): Likewise. * src/users.c (main): Likewise. * src/whoami.c (main): Likewise. * src/yes.c (main): Likewise. * configure.ac (AC_CHECK_DECLS): No need to check strtoimax, strtoumax, since gnulib does this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 0e49370de..33088e84e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -237,9 +237,6 @@ AC_CHECK_DECLS([strsignal, sys_siglist, _sys_siglist, __sys_siglist], , ,
[AC_INCLUDES_DEFAULT
#include <signal.h>])
-# For src/kill.c and src/printf.c.
-AC_CHECK_DECLS([strtoimax, strtoumax])
-
cu_LIB_CHECK
# Build df only if there's a point to it.