summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPádraig Brady <P@draigBrady.com>2015-06-06 14:17:14 +0100
committerPádraig Brady <P@draigBrady.com>2015-06-06 14:27:54 +0100
commit3150ec900c4b8f84978ca4fb80eb109ae0df875c (patch)
tree2fcf37f00b2822b84c1745a649f4b6e8b424ab99 /configure.ac
parent079652ee6b5d3987525ce225518a15253fc9d319 (diff)
downloadcoreutils-3150ec900c4b8f84978ca4fb80eb109ae0df875c.tar.xz
tests: fix false failure in recent test adjustment
* configure.ac: Comment on why we link rather than run the test, and remove the moot __ELF__ check since we never ran it anyway, and the new CFLAGS and LDFLAGS are a more direct test of support. * tests/misc/wc-parallel.sh: Fix a syntax error in the previous change. * tests/misc/md5sum-parallel.sh: Use better error checking, consistent with that used in wc-parallel.sh.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index a50992d04..fc1a0526b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -454,6 +454,7 @@ if test $gl_cv_list_mounted_fs = yes && test $gl_cv_fs_space = yes; then
gl_ADD_PROG([optional_bin_progs], [df])
fi
+# Build stdbuf only if supported
ac_save_CFLAGS=$CFLAGS
ac_save_LDFLAGS=$LDFLAGS
# Detect warnings about ignored "constructor" attributes.
@@ -464,18 +465,15 @@ AC_MSG_CHECKING([whether this system supports stdbuf])
CFLAGS="-fPIC $CFLAGS"
LDFLAGS="-shared $LDFLAGS"
stdbuf_supported=no
+# Note we only LINK here rather than RUN to support cross compilation
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[
static int stdbuf = 0;
- /* Restrict to ELF systems with compilers
- that support the constructor attribute. */
void __attribute__ ((constructor))
stdbuf_init (void)
{
- #if __ELF__
- stdbuf = 1;
- #endif
+ stdbuf = 1;
}]],[[
return !(stdbuf == 1);]])
],