summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-05-17 13:47:39 +0200
committerJim Meyering <meyering@redhat.com>2009-05-17 13:59:12 +0200
commit2726826c720d9387f631c35e9c8401abd75a1087 (patch)
tree78639bf55f3745b3d248f8b21b36514508aefedb /configure.ac
parent9593a3d8e78ece58deab5a30632021322bbc16d0 (diff)
downloadcoreutils-2726826c720d9387f631c35e9c8401abd75a1087.tar.xz
build: avoid new warnings from gcc 4.5.0 20090517
* configure.ac: Add an explicit -Wno-logical-op, now that not listing -Wlogical-op is insufficient.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b738d4a91..68a940cb2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,11 @@ if test "$gl_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-sign-compare]) # Too many warnings for now
gl_WARN_ADD([-Wno-pointer-sign]) # Too many warnings for now
gl_WARN_ADD([-Wno-unused-parameter]) # Too many warnings for now
+
+ # In spite of excluding -Wlogical-op above, it is enabled, as of
+ # gcc 4.5.0 20090517, and it provokes warnings in cat.c, dd.c, truncate.c
+ gl_WARN_ADD([-Wno-logical-op])
+
gl_WARN_ADD([-fdiagnostics-show-option])
AC_SUBST([WARN_CFLAGS])