summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2007-11-05 11:03:55 +0100
committerJim Meyering <meyering@redhat.com>2007-11-05 11:13:21 +0100
commit25e3dd5365aaab8f470e1c40b1559f3fb4ae68e4 (patch)
tree776b6a0f20ff7b086179e63ecca6d534c47f0925 /configure.ac
parentb8da93bee90a0f8ded1e3e4bd0440cc008e1a885 (diff)
downloadcoreutils-25e3dd5365aaab8f470e1c40b1559f3fb4ae68e4.tar.xz
Don't use GNU-sed-specific \< \> operators.
* configure.ac (MAN): Transform ginstall.1 to install.1 using a loop, rather than sed with \<...\>. Problem reported by Bruno Haible. Andreas Schwab reminded me that \< and \> are not portable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a685c9532..494155a18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -307,7 +307,7 @@ esac
MAN=`echo "$optional_bin_progs "|sed 's/ /.1 /g;s/ $//'`
# Change ginstall.1 to "install.h" in $MAN.
-MAN=`echo "$MAN"|sed 's/\<ginstall\.1\>/install.1/'`
+MAN=`for m in $MAN; do test $m = ginstall.1 && m=install.1; echo $m; done | tr '\012' ' '; echo`
# Remove [.1, since writing a portable rule for it in man/Makefile.am
# is not practical. The sed LHS below uses the autoconf quadrigraph