summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2008-11-12 11:11:54 +0100
committerJim Meyering <meyering@redhat.com>2008-12-21 17:49:58 +0100
commit22a2a43021e8e82226d4b33189e77673b7326c95 (patch)
treecd36b87521ab52d53ac12d930fddb698867727f6 /configure.ac
parent4000c35ae3546aca05ece49ffa01ba2a763000b0 (diff)
downloadcoreutils-22a2a43021e8e82226d4b33189e77673b7326c95.tar.xz
build: add configure-time --enable-gcc-warnings option; avoid warnings
* bootstrap.conf (gnulib_modules): Add "warnings" module. * configure.ac: Add --enable-gcc-warnings, derived from code in bison. * src/Makefile.am (AM_CFLAGS): Set to $(WARN_CFLAGS) # $(WERROR_CFLAGS) * lib/Makefile.am (AM_CFLAGS): Change spelling to $(WARN_CFLAGS) Don't use $(WERROR_CFLAGS), yet. * src/system.h (usage): Declare. * src/base64.c (usage): Declare to be global, for consistency. * src/timeout.c (usage): Likewise. * src/truncate.c (usage): Likewise. * src/getlimits.c (usage): Likewise. * src/pinky.c (ttyname): Declare with prototype, rather than an empty argument list. * src/who.c (ttyname): Likewise. * src/su.c (crypt, getusershell, setusershell, endusershell): Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 549c7ee2c..f165893a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,39 @@ gl_EARLY
gl_INIT
coreutils_MACROS
+AC_ARG_ENABLE([gcc-warnings],
+ [AS_HELP_STRING([--enable-gcc-warnings],
+ [turn on lots of GCC warnings (not recommended)])],
+ [case $enableval in
+ yes|no) ;;
+ *) AC_MSG_ERROR([bad value $enableval for gcc-warnings option]) ;;
+ esac
+ gl_gcc_warnings=$enableval],
+ [gl_gcc_warnings=no]
+)
+
+if test "$gl_gcc_warnings" = yes; then
+ gl_WARN_ADD([-Werror], [WERROR_CFLAGS])
+ AC_SUBST([WERROR_CFLAGS])
+ gl_WARN_ADD([-Wall])
+ gl_WARN_ADD([-Wextra])
+ gl_WARN_ADD([-Wshadow])
+ gl_WARN_ADD([-Wno-sign-compare])
+ gl_WARN_ADD([-Wformat])
+ gl_WARN_ADD([-Wformat-security])
+ gl_WARN_ADD([-Wcast-align])
+ gl_WARN_ADD([-Wpointer-arith])
+ gl_WARN_ADD([-Wwrite-strings])
+ gl_WARN_ADD([-Wbad-function-cast])
+ gl_WARN_ADD([-Wmissing-declarations])
+ gl_WARN_ADD([-Wmissing-prototypes])
+ gl_WARN_ADD([-Wstrict-prototypes])
+ AC_SUBST([WARN_CFLAGS])
+ AC_DEFINE([lint], 1, [Define to 1 if the compiler is checking for lint.])
+ AC_DEFINE([_FORTIFY_SOURCE], 2,
+ [enable compile-time and run-time bounds-checking, and some warnings])
+fi
+
AC_FUNC_FORK
optional_bin_progs=