summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2008-03-04 20:54:45 +0100
committerJim Meyering <meyering@redhat.com>2008-03-04 20:54:45 +0100
commit07bc841590ceccf8eac9a98d55001bb0412f5299 (patch)
tree56499039658655ddcfee2cf51b2a4da2f9608665 /configure.ac
parentdd647e78ca073723c0e3c2d7de243be0b7ab2108 (diff)
downloadcoreutils-07bc841590ceccf8eac9a98d55001bb0412f5299.tar.xz
Reinstate GNUmakefile patch, but with workaround for automake.
* configure.ac (AC_CONFIG_LINKS): Use shell variable to bypass automake distclean rules. * Makefile.am (distclean-local): Clean GNUmakefile in VPATH builds, since we are bypassing automake. * GNUmakefile (_is-dist-target): 'distclean' is not a dist target.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d55b2da50..cc4e15295 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,13 +337,15 @@ dnl Allow maintainer rules under GNU make even in VPATH builds. This does
dnl not work in autoconf 2.61 or earlier, but we don't want to require
dnl non-maintainers to use unreleased autoconf, hence the version test.
dnl TODO remove the version check once autoconf 2.62 is released.
-
-dnl Disabled for now, since this would cause "make distclean" to
-dnl remove the sole copy of GNUmakefile in a non-VPATH build.
-dnl TODO restore once automake has been fixed to do the right thing.
-dnl m4_if(m4_version_compare([2.61a.100],
-dnl m4_defn([m4_PACKAGE_VERSION])), [1], [],
-dnl [AC_CONFIG_LINKS([GNUmakefile:GNUmakefile])])
+dnl Meanwhile, we must use a shell variable so that we bypass automake's
+dnl attempts to remove the sole copy of GNUmakefile in a non-VPATH build
+dnl during 'make distclean'.
+dnl TODO avoid the shell variable once automake is fixed.
+GNUmakefile=GNUmakefile
+m4_if(m4_version_compare([2.61a.100],
+ m4_defn([m4_PACKAGE_VERSION])), [1], [],
+ [AC_CONFIG_LINKS([$GNUmakefile:$GNUmakefile], [],
+ [GNUmakefile=$GNUmakefile])])
AC_CONFIG_FILES(
Makefile