summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-08-29 14:22:47 +0200
committerJim Meyering <meyering@redhat.com>2012-08-30 15:21:59 +0200
commitf56980b99cadfe93fc208da781985786fdab87ce (patch)
tree7bcfe2692d04df6e509b9ea849be52987847b099 /Makefile.am
parentd1b490c10da134859e7819c2f6b837e8da3df576 (diff)
downloadcoreutils-f56980b99cadfe93fc208da781985786fdab87ce.tar.xz
build: don't use recursive make to build the 'doc' subdirectory
* doc/Makefile.am: Rename ... * doc/local.mk: ... like this. With further adjustments ... (info_TEXINFOS): Prepend 'doc/' to all '*.texi' files listed in here. (coreutils_TEXINFOS): Likewise, and rename ... (doc_coreutils_TEXINFOS): ... like this. (constants.texi): Rename ... (doc/constants.texi): ... like this. Adjust the recipe to avoid spurious errors. (MAINTAINERCLEANFILES): Adjust, and extend with '+=' rather than setting it with '='. (ME): Delete. (find_upper_case_var): Use '$@', not '$(ME)', in error messages. * Makefile.am: Include 'doc/local.mk'. (SUBDIRS): Remove 'doc'. * configure.ac (AC_CONFIG_FILES): Remove 'doc/Makefile'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 72d93d544..0446e4344 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -17,7 +17,7 @@
ALL_RECURSIVE_TARGETS =
-SUBDIRS = lib src doc man po tests gnulib-tests
+SUBDIRS = lib src man po tests gnulib-tests
changelog_etc = \
ChangeLog-2005 \
@@ -169,3 +169,5 @@ check-git-hook-script-sync:
done; \
rm -rf $$t; \
test $$fail = 0
+
+include $(top_srcdir)/doc/local.mk