summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-06-26 13:33:59 +0200
committerJim Meyering <meyering@redhat.com>2009-06-27 09:16:59 +0200
commite472f8fece400b6cb8a93dee7476cdb257f64d2f (patch)
treec7cfb3143435ff8e739ee187b073eade361839a1 /Makefile.am
parent1c16c9598e67e0db641af8b85abf8c009e3a9226 (diff)
downloadcoreutils-e472f8fece400b6cb8a93dee7476cdb257f64d2f.tar.xz
maint: add a rule to automate the annual copyright-year-update process
* build-aux/update-copyright: New file. * Makefile.am (changelog_etc): Add update-copyright. (update-copyright): New rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 99fc937f8..87e45451e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,7 @@ changelog_etc = \
ChangeLog-2007 \
ChangeLog-2008 \
build-aux/ChangeLog-2007 \
+ build-aux/update-copyright \
doc/ChangeLog-2007 \
lib/ChangeLog-2007 \
m4/ChangeLog-2007 \
@@ -143,3 +144,11 @@ check-ls-dircolors:
|sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
|sed -n 's/^"\(..\)"/\1/p'|sort -u); \
test "$$dc" = "$$ls"
+
+.PHONY: update-copyright
+update-copyright:
+ if test -d .git; then \
+ git grep -l -E '2[0-9]{3} +Free' \
+ | grep -v -E '^(COPYING|ChangeLog)' \
+ | xargs $(srcdir)/build-aux/$@; \
+ fi