summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <jim@meyering.net>2002-07-01 08:13:49 +0000
committerJim Meyering <jim@meyering.net>2002-07-01 08:13:49 +0000
commitabb32bb0ae5897e78ef78d4fac7d406da69d5f7c (patch)
tree99b4274ac3c909c045a917aa456a11bf79fe8d73 /Makefile.am
parent5ad73398f4790f6d6cc416e06a148b256bf689fb (diff)
downloadcoreutils-abb32bb0ae5897e78ef78d4fac7d406da69d5f7c.tar.xz
Merge the three files from fileutils, textutils, and sh-utils.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 000000000..26d4ba7f2
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+## Process this file with automake to produce Makefile.in -*-Makefile-*-
+
+SUBDIRS = lib src doc man m4 po tests djgpp
+EXTRA_DIST = Makefile.cfg Makefile.maint GNUmakefile \
+ .kludge-stamp .prev-version
+
+install-root:
+ cd src && $(MAKE) $@
+
+ACLOCAL_AMFLAGS = -I m4
+
+# Some tests always need root privileges, others need them only sometimes.
+check-root:
+ cd tests && $(MAKE) $@
+
+distcheck-hook:
+ $(MAKE) my-distcheck
+
+# Just prior to distribution, ...
+# transform the automake-generated rule that runs `rm -f rm'.
+# On some systems, that command would fail with a diagnostic like
+# `rm: cannot unlink `rm': Text file busy' when `.' appears so early
+# in the shell's search path that running `rm' would run the `rm'
+# executable in the current directory.
+# Similarly, adjust the clean-binPROGRAMS rule.
+
+rm_subst = \
+ s!(rm -f (rm|\$$\(bin_PROGRAMS\)))$$!$$1 > /dev/null 2>&1 || /bin/$$1!
+.kludge-stamp: $(srcdir)/src/Makefile.in
+ perl -pi -e '$(rm_subst)' $(srcdir)/src/Makefile.in
+ touch $@