summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBernhard Voelker <mail@bernhard-voelker.de>2011-09-19 20:00:56 +0200
committerJim Meyering <meyering@redhat.com>2011-09-24 13:17:21 +0200
commit57db1fc2a97add508d43cf163d2a5f4f381d2837 (patch)
treebf06626cfc439d5c5c66ce6b712b86d2276ffd2a /Makefile.am
parent80a1aca0d2fad9d151a66ae5e612b96172bd5cbe (diff)
downloadcoreutils-57db1fc2a97add508d43cf163d2a5f4f381d2837.tar.xz
tests: introduce make targets check-expensive and check-very-expensive
* Makefile.am: add shortcuts to run (very) expensive tests. Use "make check-expensive" to run tests with RUN_EXPENSIVE_TESTS=yes, use "make check-very-expensive" to run tests with both RUN_EXPENSIVE_TESTS=yes and RUN_VERY_EXPENSIVE_TESTS=yes. Non-expensive tests are included in all cases.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f737cf6c5..0359717bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,12 @@ ALL_RECURSIVE_TARGETS += check-root
check-root:
cd tests && $(MAKE) $@ SUBDIRS=
+# Shortcut targets to make it easier to run (very) expensive tests.
+check-expensive:
+ $(MAKE) check RUN_EXPENSIVE_TESTS=yes
+check-very-expensive:
+ $(MAKE) check-expensive RUN_VERY_EXPENSIVE_TESTS=yes
+
# Just prior to distribution, ...
# transform the automake-generated rule that runs `rm -f rm'.
# On some systems, that command would fail with a diagnostic like