summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-04-11 14:48:49 +0200
committerJim Meyering <meyering@redhat.com>2009-04-11 15:20:37 +0200
commit4404198c12b5d378ed03cbc1547f87011b4d3fb2 (patch)
treef6f3185d1c84e13ea0fb80960b3cc1a9fa134c83 /Makefile.am
parent0523f45f668ae09778f171c34e4f1f0c8360be82 (diff)
downloadcoreutils-4404198c12b5d378ed03cbc1547f87011b4d3fb2.tar.xz
build: avoid parallel distcheck failure
* Makefile.am (ALL_RECURSIVE_TARGETS): Initialize here, too, to please automake. Add install-root, check-root, distcheck-hook. * cfg.mk (ALL_RECURSIVE_TARGETS): Add sc_tight_scope. * maint.mk (ALL_RECURSIVE_TARGETS): Add patch-check, check-AUTHORS, maintainer-distcheck, vc-dist, taint-distcheck, my-distcheck, alpha, beta, major.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 088cf4fa5..13891ee9c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,8 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
+ALL_RECURSIVE_TARGETS =
+
SUBDIRS = lib src doc man po tests gnulib-tests
changelog_etc = \
@@ -67,12 +69,14 @@ EXTRA_DIST = \
gl/modules/getloadavg.diff \
maint.mk
+ALL_RECURSIVE_TARGETS += install-root
install-root:
cd src && $(MAKE) $@
ACLOCAL_AMFLAGS = -I m4
# Some tests always need root privileges, others need them only sometimes.
+ALL_RECURSIVE_TARGETS += check-root
check-root:
cd tests && $(MAKE) $@ SUBDIRS=
@@ -108,6 +112,7 @@ gen-ChangeLog:
mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi
+ALL_RECURSIVE_TARGETS += distcheck-hook
distcheck-hook: check-ls-dircolors
$(MAKE) my-distcheck