summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Youngman <jay@gnu.org>2008-02-19 13:27:39 +0100
committerJim Meyering <meyering@redhat.com>2008-02-19 13:31:56 +0100
commit4242d4f5c4f32374b684882a74e1b773ad01b1d6 (patch)
treee8abc68be6d25dd3556516cab759524e58e96e77 /Makefile.am
parentb8108fd2ddf77ae79cd014f4f37798a52be13fd1 (diff)
downloadcoreutils-4242d4f5c4f32374b684882a74e1b773ad01b1d6.tar.xz
Fix non-srcdir "make distcheck" failure.
* Makefile.am (check-ls-dircolors): Look for sources under $(srcdir), not under ".".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index fcf5cfaf7..67f493484 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,10 +108,12 @@ THANKS-to-translators: po/LINGUAS THANKStt.in
# remain in sync.
.PHONY: check-ls-dircolors
check-ls-dircolors:
- dc=$$(sed -n '/static.*ls_codes\[/,/};'/p src/dircolors.c \
- |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
- |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
- ls=$$(sed -n '/static.*indicator_name\[/,/};'/p src/ls.c \
- |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
- |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
+ dc=$$(sed -n '/static.*ls_codes\[/,/};'/p \
+ $(srcdir)/src/dircolors.c \
+ |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
+ |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
+ ls=$$(sed -n '/static.*indicator_name\[/,/};'/\p \
+ $(srcdir)/src/ls.c \
+ |sed -n '/^ *"/p'|tr , '\n'|sed 's/^ *//' \
+ |sed -n 's/^"\(..\)"/\1/p'|sort -u); \
test "$$dc" = "$$ls"