summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2011-03-14 14:26:38 +0100
committerJim Meyering <meyering@redhat.com>2011-03-16 12:22:22 +0100
commit8e4e1d484f88502dbe9336050232a5f90e0b68d4 (patch)
treeaa9036ddd6b86e42888e5e10ea5762fb2ae58cc8 /Makefile.am
parent0ddfd54b08dfe4e78b8aa2dd74378e5b62c9d68c (diff)
downloadcoreutils-8e4e1d484f88502dbe9336050232a5f90e0b68d4.tar.xz
maint: stop using .x-sc_* files to list syntax-check exemptions
Instead, use the brand new mechanism with which you merely use a variable (derived from the rule name) defined in cfg.mk to an ERE matching the exempted file names. * gnulib: Update to latest, to get maint.mk that implements this. * Makefile.am (syntax_check_exceptions): Remove variable. (EXTRA_DIST): Remove use of the variable. * cfg.mk (sc_x_sc_dist_check): Remove rule, no longer useful. (exclude_file_name_regexp--sc_space_tab): Define variable. (exclude_file_name_regexp--sc_bindtextdomain): Likewise. (exclude_file_name_regexp--sc_unmarked_diagnostics): Likewise. (exclude_file_name_regexp--sc_error_message_uppercase): Likewise. (exclude_file_name_regexp--sc_trailing_blank): Likewise. (exclude_file_name_regexp--sc_system_h_headers): Likewise. (exclude_file_name_regexp--sc_require_config_h_first): Likewise. (exclude_file_name_regexp--sc_require_config_h): Likewise. (exclude_file_name_regexp--sc_po_check): Likewise. (exclude_file_name_regexp--sc_prohibit_always-defined_macros): Likewise. (exclude_file_name_regexp--sc_prohibit_empty_lines_at_EOF): Likewise. (exclude_file_name_regexp--sc_program_name): Likewise. (exclude_file_name_regexp--sc_file_system): Likewise. (exclude_file_name_regexp--sc_prohibit_always_true_header_tests): Likewise. (exclude_file_name_regexp--sc_prohibit_fail_0): Likewise. (exclude_file_name_regexp--sc_prohibit_atoi_atof): Likewise. (exclude_file_name_regexp--sc_prohibit_tab_based_indentation): Likewise. (exclude_file_name_regexp--sc_prohibit_stat_st_blocks): Likewise. * configure.ac [whether localtime caches TZ]: Use return 0/1, not exit (0/1) to avoid triggering a sc_prohibit_magic_number_exit failure. * .x-sc_GPL_version: Remove file. * .x-sc_bindtextdomain: Likewise. * .x-sc_error_message_uppercase: Likewise. * .x-sc_file_system: Likewise. * .x-sc_obsolete_symbols: Likewise. * .x-sc_po_check: Likewise. * .x-sc_program_name: Likewise. * .x-sc_prohibit_always-defined_macros: Likewise. * .x-sc_prohibit_always_true_header_tests: Likewise. * .x-sc_prohibit_atoi_atof: Likewise. * .x-sc_prohibit_empty_lines_at_EOF: Likewise. * .x-sc_prohibit_fail_0: Likewise. * .x-sc_prohibit_magic_number_exit: Likewise. * .x-sc_prohibit_stat_st_blocks: Likewise. * .x-sc_prohibit_strcmp: Likewise. * .x-sc_prohibit_tab_based_indentation: Likewise. * .x-sc_require_config_h: Likewise. * .x-sc_require_config_h_first: Likewise. * .x-sc_space_tab (config): Likewise. * .x-sc_sun_os_names: Likewise. * .x-sc_system_h_headers: Likewise. * .x-sc_trailing_blank: Likewise. * .x-sc_unmarked_diagnostics: Likewise. * .x-sc_useless_cpp_parens: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 0 insertions, 27 deletions
diff --git a/Makefile.am b/Makefile.am
index 18f09b79e..9322658f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,35 +39,8 @@ changelog_etc = \
old/textutils/NEWS \
po/ChangeLog-2007
-syntax_check_exceptions = \
- .x-sc_GPL_version \
- .x-sc_bindtextdomain \
- .x-sc_error_message_uppercase \
- .x-sc_file_system \
- .x-sc_obsolete_symbols \
- .x-sc_po_check \
- .x-sc_program_name \
- .x-sc_prohibit_always-defined_macros \
- .x-sc_prohibit_atoi_atof \
- .x-sc_prohibit_empty_lines_at_EOF \
- .x-sc_prohibit_fail_0 \
- .x-sc_prohibit_magic_number_exit \
- .x-sc_prohibit_stat_st_blocks \
- .x-sc_prohibit_strcmp \
- .x-sc_prohibit_tab_based_indentation \
- .x-sc_require_config_h \
- .x-sc_require_config_h_first \
- .x-sc_space_tab \
- .x-sc_sun_os_names \
- .x-sc_system_h_headers \
- .x-sc_trailing_blank \
- .x-sc_prohibit_always_true_header_tests \
- .x-sc_unmarked_diagnostics \
- .x-sc_useless_cpp_parens
-
EXTRA_DIST = \
$(changelog_etc) \
- $(syntax_check_exceptions) \
.mailmap \
.prev-version \
.version \