summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2008-03-04 20:54:45 +0100
committerJim Meyering <meyering@redhat.com>2008-03-04 20:54:45 +0100
commit07bc841590ceccf8eac9a98d55001bb0412f5299 (patch)
tree56499039658655ddcfee2cf51b2a4da2f9608665 /Makefile.am
parentdd647e78ca073723c0e3c2d7de243be0b7ab2108 (diff)
downloadcoreutils-07bc841590ceccf8eac9a98d55001bb0412f5299.tar.xz
Reinstate GNUmakefile patch, but with workaround for automake.
* configure.ac (AC_CONFIG_LINKS): Use shell variable to bypass automake distclean rules. * Makefile.am (distclean-local): Clean GNUmakefile in VPATH builds, since we are bypassing automake. * GNUmakefile (_is-dist-target): 'distclean' is not a dist target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 67f493484..28629400c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,6 +94,11 @@ gen-ChangeLog:
distcheck-hook: check-ls-dircolors
$(MAKE) my-distcheck
+# Arrange to remove the symlink to GNUmakefile in VPATH builds.
+# TODO remove this once automake vs. AC_CONFIG_LINKS issue is fixed.
+distclean-local:
+ if test x"$(VPATH)" != x ; then rm -f GNUmakefile ; fi
+
DISTCLEANFILES = VERSION
MAINTAINERCLEANFILES = THANKS-to-translators
THANKS-to-translators: po/LINGUAS THANKStt.in