summaryrefslogtreecommitdiff
path: root/python-pynest2d/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'python-pynest2d/PKGBUILD')
-rw-r--r--python-pynest2d/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/python-pynest2d/PKGBUILD b/python-pynest2d/PKGBUILD
new file mode 100644
index 000000000..3dc39e158
--- /dev/null
+++ b/python-pynest2d/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Erich Eckner <arch at eckner dot net>
+# Contributor: Jelle van der Waa <jelle@archlinux.org>
+
+pkgname=python-pynest2d
+pkgver=4.12.0
+pkgrel=1
+pkgdesc="Python bindings for libnest2d"
+arch=(x86_64)
+url="https://github.com/Ultimaker/pynest2d"
+license=("LGPL")
+depends=('python>=3.10' 'python<3.11' polyclipping nlopt)
+makedepends=(sip4 cmake boost libnest2d)
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/Ultimaker/pynest2d/archive/${pkgver}.tar.gz)
+sha512sums=('67451e3817aa308827683153c9f1fae670d95d393fad3b9b10831f7e255469df3be73fa2f90101c6dbf4034c06b51c4b3d9a4aa242f36325bb943003b0ce1842')
+
+prepare() {
+ cd pynest2d-${pkgver}
+
+ mkdir build
+}
+
+build() {
+ cd pynest2d-${pkgver}/build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd pynest2d-${pkgver}/build
+ make DESTDIR="${pkgdir}" install
+}