summaryrefslogtreecommitdiff
path: root/perl-perinci-sub-propertyutil/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-perinci-sub-propertyutil/PKGBUILD')
-rw-r--r--perl-perinci-sub-propertyutil/PKGBUILD74
1 files changed, 0 insertions, 74 deletions
diff --git a/perl-perinci-sub-propertyutil/PKGBUILD b/perl-perinci-sub-propertyutil/PKGBUILD
deleted file mode 100644
index 71547cdb8..000000000
--- a/perl-perinci-sub-propertyutil/PKGBUILD
+++ /dev/null
@@ -1,74 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (97841193a0046800a1ed3cebc0718afe92066b6f1190519a623e66830c355902620a8d956439b9825c773ea4af1a5a3ff917dc0d9a50bafb588ca09da5980c74)
-
-pkgname='perl-perinci-sub-propertyutil'
-pkgver='0.11'
-pkgrel=10
-pkgdesc='Utility routines for Perinci::Sub::Property::* modules'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-exporter'
- 'perl-sah-schemas-rinci>=1.1.80'
-)
-makedepends=(
- 'perl'
- 'perl-extutils-makemaker'
- 'perl-io'
- 'perl-pathtools'
- 'perl-test-simple'
-)
-url='https://metacpan.org/release/Perinci-Sub-PropertyUtil'
-_distdir="Perinci-Sub-PropertyUtil-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/P/PE/PERLANCAR/${_distdir}.tar.gz")
-sha512sums=('ea0f38db3194c4a1d0b492b9e1c594824d4a2175cbf9cf92dd5023d4ab7d9c354352d28da65cd40d699d0e8fbc0a7e052990cba29dbe838224c9be3517504b41')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}