summaryrefslogtreecommitdiff
path: root/perl-mojolicious-plugin-assetpack/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-mojolicious-plugin-assetpack/PKGBUILD')
-rw-r--r--perl-mojolicious-plugin-assetpack/PKGBUILD70
1 files changed, 0 insertions, 70 deletions
diff --git a/perl-mojolicious-plugin-assetpack/PKGBUILD b/perl-mojolicious-plugin-assetpack/PKGBUILD
deleted file mode 100644
index e0bb3f08d..000000000
--- a/perl-mojolicious-plugin-assetpack/PKGBUILD
+++ /dev/null
@@ -1,70 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (2187f3ca33d7c791f08a9ab8c3893497ec9caa377e13a9f4565f67f0abb693a7e3c3edb2792f2bae0865f195eb47b422ea736d98c72a803ee24cecfcdfa2829f)
-
-pkgname='perl-mojolicious-plugin-assetpack'
-pkgver=2.11
-pkgrel=5
-pkgdesc='Compress and convert css, less, sass, javascript and coffeescript files'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-makedepends=(
- 'perl-extutils-makemaker'
- 'perl-test-simple>=0.88')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-file-which>=1.21'
- 'perl-ipc-run3>=0.048'
- 'perl-mojolicious>=7.17')
-url='https://metacpan.org/release/Mojolicious-Plugin-AssetPack'
-_distdir="Mojolicious-Plugin-AssetPack-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/J/JH/JHTHORSEN/${_distdir}.tar.gz")
-sha512sums=('738353141fbc07318318d15f989fb2c4b7a30a8c68955dea5c40dd2b4573aa1aeb5a8efb2141200734a17193e89239f64589ba8a047e2ed4d362f9100725b6ad')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}