summaryrefslogtreecommitdiff
path: root/perl-mixin-linewise/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-mixin-linewise/PKGBUILD')
-rw-r--r--perl-mixin-linewise/PKGBUILD61
1 files changed, 0 insertions, 61 deletions
diff --git a/perl-mixin-linewise/PKGBUILD b/perl-mixin-linewise/PKGBUILD
deleted file mode 100644
index c7c58d40e..000000000
--- a/perl-mixin-linewise/PKGBUILD
+++ /dev/null
@@ -1,61 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.27
-
-pkgname='perl-mixin-linewise'
-pkgver=0.111
-pkgrel=2
-pkgdesc="write your linewise code for handles; this does the rest"
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-carp'
- 'perl-io'
- 'perl-perlio-utf8-strict'
- 'perl-sub-exporter')
-makedepends=(
- 'perl-encode'
- 'perl-extutils-makemaker>=6.78'
- 'perl-lib'
- 'perl-pathtools'
- 'perl-test-simple>=0.96')
-url='http://search.mcpan.org/dist/Mixin-Linewise'
-source=("http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Mixin-Linewise-${pkgver}.tar.gz")
-sha512sums=('282c9bbb825ee05f1d916fdfb1caad6c04a917a26c10ae18dc9883706e612915186c49a96209af254329f346bc731547a20ff2db136f0ceaf1edd5d21b120195')
-_distdir="Mixin-Linewise-${pkgver}"
-
-build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
-}
-
-check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
-}
-
-package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: