summaryrefslogtreecommitdiff
path: root/perl-log-contextual/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-log-contextual/PKGBUILD')
-rw-r--r--perl-log-contextual/PKGBUILD78
1 files changed, 0 insertions, 78 deletions
diff --git a/perl-log-contextual/PKGBUILD b/perl-log-contextual/PKGBUILD
deleted file mode 100644
index b9f4cdf52..000000000
--- a/perl-log-contextual/PKGBUILD
+++ /dev/null
@@ -1,78 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (2187f3ca33d7c791f08a9ab8c3893497ec9caa377e13a9f4565f67f0abb693a7e3c3edb2792f2bae0865f195eb47b422ea736d98c72a803ee24cecfcdfa2829f)
-
-pkgname='perl-log-contextual'
-pkgver=0.008001
-pkgrel=9
-pkgdesc='Simple logging interface with a contextual log'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-carp'
- 'perl-data-dumper-concise'
- 'perl-exporter-declare>=0.111'
- 'perl-moo>=1.003'
- 'perl-scalar-list-utils'
-)
-makedepends=(
- 'perl-extutils-makemaker'
- 'perl-test-fatal'
-)
-checkdepends=(
- 'perl-log-log4perl'
- 'perl-test-pod'
-)
-url='https://metacpan.org/release/Log-Contextual'
-_distdir="Log-Contextual-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/F/FR/FREW/${_distdir}.tar.gz")
-sha512sums=('225f209cab7aa36d0fcc0990d9e43609e54077ef0f4df073e2f81933d8789ac9b7f26958d5b7d54be416fa71174e92c1af706e736da8ec20edf10ee0277cdf2d')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}