summaryrefslogtreecommitdiff
path: root/perl-config-inifiles/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-config-inifiles/PKGBUILD')
-rw-r--r--perl-config-inifiles/PKGBUILD81
1 files changed, 0 insertions, 81 deletions
diff --git a/perl-config-inifiles/PKGBUILD b/perl-config-inifiles/PKGBUILD
deleted file mode 100644
index eb80a5f31..000000000
--- a/perl-config-inifiles/PKGBUILD
+++ /dev/null
@@ -1,81 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (2187f3ca33d7c791f08a9ab8c3893497ec9caa377e13a9f4565f67f0abb693a7e3c3edb2792f2bae0865f195eb47b422ea736d98c72a803ee24cecfcdfa2829f)
-
-pkgname='perl-config-inifiles'
-pkgver=3.000003
-pkgrel=7
-pkgdesc='A module for reading .ini-style configuration files.'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-makedepends=(
- 'perl'
- 'perl-base'
- 'perl-exporter'
- 'perl-extutils-makemaker'
- 'perl-file-temp'
- 'perl-io'
- 'perl-lib'
- 'perl-module-build>=0.28'
- 'perl-parent'
- 'perl-pathtools'
- 'perl-scalar-list-utils'
- 'perl-test-simple>=0.88')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-carp'
- 'perl-file-temp'
- 'perl-io-stringy'
- 'perl-scalar-list-utils>=1.33')
-url='https://metacpan.org/release/Config-IniFiles'
-_distdir="Config-IniFiles-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/${_distdir}.tar.gz")
-sha512sums=('29278b7f6aaf9ffcc0cd8b48ca0e1f1084b10278e50764b2b93e3e9b156ef13d6e54f779f41d0a6cbf6e0b23da1b73a3bb83fbf873add0a604693a41312b91f5')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}