summaryrefslogtreecommitdiff
path: root/perl-class-dbi-plugin/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-class-dbi-plugin/PKGBUILD')
-rw-r--r--perl-class-dbi-plugin/PKGBUILD66
1 files changed, 0 insertions, 66 deletions
diff --git a/perl-class-dbi-plugin/PKGBUILD b/perl-class-dbi-plugin/PKGBUILD
deleted file mode 100644
index d4e4e4fc5..000000000
--- a/perl-class-dbi-plugin/PKGBUILD
+++ /dev/null
@@ -1,66 +0,0 @@
-# Maintainer: Erich Eckner <arch at eckner dot net>
-# Generator : neuesPerlPaket (1defbcf32afb33ec54a2b45a3b72b4d049f690f6dbc08511ad48f4db6f85a4ecd583a13fcec1172e0d3c1ca342a483beb851ba887d67450c25231cc0aafdf66b)
-
-pkgname='perl-class-dbi-plugin'
-pkgver='0.03'
-pkgrel=9
-pkgdesc='Abstract base class for Class::DBI plugins'
-arch=('any')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=(
- 'perl>=5.38'
- 'perl<5.39'
- 'perl-class-dbi>=0.9'
-)
-url='https://metacpan.org/release/Class-DBI-Plugin'
-_distdir="Class-DBI-Plugin-${pkgver}"
-source=("https://cpan.metacpan.org/authors/id/J/JC/JCZEUS/${_distdir}.tar.gz")
-sha512sums=('1e42673d2cee46f3d2b763de9236c4bd6603d0f85e8eae9cca49d90fd4353dd2a43adf6dbad403774f72ad11090130f5234af85c18ba3192e4bf924e020350bc')
-
-build() {
- cd "${srcdir}/${_distdir}"
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='${pkgdir}'" \
- PERL_MB_OPT="--installdirs vendor --destdir '${pkgdir}'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- perl Makefile.PL
- make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build.PL
- perl Build
- fi
-}
-
-check() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
- fi
-}
-
-package() {
- cd "${srcdir}/${_distdir}"
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
-
- # remove perllocal.pod and .packlist
- find "${pkgdir}" -name .packlist -o -name perllocal.pod -delete
-}