# Maintainer: Erich Eckner <arch at eckner dot net>
pkgname=xraylarch
pkgver=0.9.27
pkgrel=4
pkgdesc="Data Analysis Tools for X-ray Spectroscopy"
arch=('any')
url="http://xraypy.github.io/xraylarch/"
license=('BSD')
groups=()
depends=(
  'python2'
  'python2-sqlalchemy'
  'python2-scipy'
  'python2-matplotlib'
  'python2-h5py'
  'python2-numpy'
  'wxpython'
  'python2-wxutils'
  'python2-wxmplot'
)
makedepends=()
checkdepends=()
optdepends=(
  'python2-termcolor:  needed for color-enhanced error messages'
  'python2-epics:      needed for using the EPICS control system'
)
provides=()
conflicts=()
replaces=()
backup=()
options=()
source=(
    "${pkgname}-${pkgver}.tar.gz::https://github.com/xraypy/${pkgname}/archive/${pkgver}.tar.gz"
)
sha256sums=(
    "df85ba8002eda05d388f9564f01881b5ee2ff5eb86c8577c9e35592bc13cc67f"
)

build() {

    cd ${pkgname}-${pkgver}
#    sed "s|DEBUG = False|DEBUG = True|" -i setup.py
    python2 setup.py build

}

package() {

    cd ${pkgname}-${pkgver}
    python2 setup.py install --skip-build --root="${pkgdir}" --prefix=/usr
    sed "s| python\$| python2|" -i $pkgdir/usr/bin/*

}