summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac163
1 files changed, 87 insertions, 76 deletions
diff --git a/configure.ac b/configure.ac
index a13a12f0..52e2b7f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,12 +13,12 @@ dnl *
dnl * ========================================================================
dnl */
-AC_PREREQ([2.57])
+AC_PREREQ([2.69])
AC_REVISION([Rev:1 by chappa@washington.edu])
dnl Alpine Version Number is in $srcdir/VERSION
-AC_INIT(alpine, m4_normalize(m4_include([VERSION])), [chappa@washington.edu])
+AC_INIT([alpine],[m4_normalize(m4_include(VERSION))],[chappa@washington.edu])
AC_CONFIG_SRCDIR([include/system.h])
AC_CONFIG_HEADERS([include/config.h])
@@ -45,7 +45,7 @@ AC_PROG_MAKE_SET
AC_PROG_LN_S
AC_PROG_AWK
AC_PROG_RANLIB
-AC_PROG_LIBTOOL
+LT_INIT
AC_PATH_PROG(AR, ar, ar)
AC_PATH_PROG(RM, rm, rm)
@@ -62,7 +62,7 @@ AM_GNU_GETTEXT([external])
dnl enable dmalloc per http://dmalloc.com
dnl NOTE: does not check c-client
AC_MSG_CHECKING([option: dmalloc enabled])
-AC_ARG_ENABLE(dmalloc, AC_HELP_STRING([--enable-dmalloc],[Enable dmalloc debugging]))
+AC_ARG_ENABLE(dmalloc, AS_HELP_STRING([--enable-dmalloc],[Enable dmalloc debugging]))
if test x$enable_dmalloc = "xyes" ; then
AC_MSG_RESULT([yes])
else
@@ -70,7 +70,7 @@ else
fi
AC_ARG_WITH(dmalloc-dir,
- AC_HELP_STRING([--with-dmalloc-dir=DIR], [Root of dmalloc lib/include path]),
+ AS_HELP_STRING([--with-dmalloc-dir=DIR],[Root of dmalloc lib/include path]),
[
if test "x$withval" != "xno" ; then
enable_dmalloc = "yes"
@@ -85,7 +85,7 @@ fi
localedir="\${datadir}/locale"
AC_ARG_WITH(localedir,
- AC_HELP_STRING([--with-localedir=DIR], [Name of gettext locale directory]),
+ AS_HELP_STRING([--with-localedir=DIR],[Name of gettext locale directory]),
[
case $withval in
yes)
@@ -104,7 +104,7 @@ case "$host" in
*darwin*)
dnl OS X Universal Binary Support
AC_ARG_ENABLE(osx-universal-binaries,
- AC_HELP_STRING([--enable-osx-universal-binaries],[Produce universal binaries under OS X [[default=no]]]))
+ AS_HELP_STRING([--enable-osx-universal-binaries],[Produce universal binaries under OS X [[default=no]]]))
if test "x$enable_osx_universal_binaries" = "xyes" ; then
if test "x$enable_dependency_tracking" != xno ; then
AC_MSG_ERROR([--enable-osx-universal-binary requires --disable-dependency-tracking.
@@ -129,7 +129,7 @@ Please re-run configure with these options:
esac
AC_ARG_WITH(include-path,
- AC_HELP_STRING([--with-include-path=PATHS], [Colon-separated list of directories used for include file search]),
+ AS_HELP_STRING([--with-include-path=PATHS],[Colon-separated list of directories used for include file search]),
[
case $withval in
no)
@@ -145,7 +145,7 @@ AC_ARG_WITH(include-path,
])
AC_ARG_WITH(lib-path,
- AC_HELP_STRING([--with-lib-path=PATHS], [Colon-separated list of directories used for library search]),
+ AS_HELP_STRING([--with-lib-path=PATHS],[Colon-separated list of directories used for library search]),
[
case $withval in
no)
@@ -161,7 +161,7 @@ AC_ARG_WITH(lib-path,
])
AC_ARG_WITH(pubcookie,
- AC_HELP_STRING([--with-pubcookie], [Include support for UW-Pubcookie Web Authentication]),
+ AS_HELP_STRING([--with-pubcookie],[Include support for UW-Pubcookie Web Authentication]),
[
if test "x$withval" != "xno" ; then
WEB_PUBCOOKIE_BUILD=web/src/pubcookie
@@ -170,7 +170,7 @@ AC_ARG_WITH(pubcookie,
AC_ARG_WITH(web-bin,
- AC_HELP_STRING([--with-web-bin=PATH], [Directory to hold Web Alpine component binary files]),
+ AS_HELP_STRING([--with-web-bin=PATH],[Directory to hold Web Alpine component binary files]),
[
case "$withval" in
no)
@@ -185,7 +185,7 @@ AC_ARG_WITH(web-bin,
dnl disable debug, turned on by default
AC_MSG_CHECKING([option: debugging is enabled])
-AC_ARG_ENABLE(debug, AC_HELP_STRING([--disable-debug],[Exclude debug messages from source]))
+AC_ARG_ENABLE(debug, AS_HELP_STRING([--disable-debug],[Exclude debug messages from source]))
if test x$enable_debug != "xno" ; then
AM_CFLAGS="$AM_CFLAGS -g"
AC_DEFINE([DEBUG], [1], [Compile in debugging])
@@ -198,7 +198,7 @@ fi
dnl disable optimization, on by default
AC_MSG_CHECKING([option: optimization is enabled])
-AC_ARG_ENABLE(optimization, AC_HELP_STRING([--disable-optimization],[Exclude optimizing compiler flags]))
+AC_ARG_ENABLE(optimization, AS_HELP_STRING([--disable-optimization],[Exclude optimizing compiler flags]))
if test x$enable_optimization != "xno" ; then
AC_MSG_RESULT([yes])
else
@@ -209,7 +209,7 @@ fi
dnl disable mouse support
AC_MSG_CHECKING([option: mouse support enabled])
-AC_ARG_ENABLE(mouse, AC_HELP_STRING([--disable-mouse], [Disable mouse support]))
+AC_ARG_ENABLE(mouse, AS_HELP_STRING([--disable-mouse],[Disable mouse support]))
if test x$enable_mouse != "xno" ; then
AC_DEFINE([MOUSE], [], [Compile in mouse support])
AC_MSG_RESULT([yes])
@@ -219,7 +219,7 @@ fi
dnl enable quotas
AC_MSG_CHECKING([option: quotas enabled])
-AC_ARG_ENABLE(quotas, AC_HELP_STRING([--enable-quotas],[Enable disk quota checking on startup]))
+AC_ARG_ENABLE(quotas, AS_HELP_STRING([--enable-quotas],[Enable disk quota checking on startup]))
if test x$enable_quotas = "xyes" ; then
AC_DEFINE([USE_QUOTAS], [], [Compile in quota check on startup])
AC_MSG_RESULT([yes])
@@ -228,7 +228,7 @@ else
fi
AC_MSG_CHECKING([option: From changing enabled])
-AC_ARG_ENABLE(from_changing, AC_HELP_STRING([--disable-from-changing],[Disallow users changing From addresss]))
+AC_ARG_ENABLE(from_changing, AS_HELP_STRING([--disable-from-changing],[Disallow users changing From addresss]))
if test x$enable_from_changing != "xno" ; then
AC_MSG_RESULT([yes])
else
@@ -238,7 +238,7 @@ fi
dnl enable background posting support
AC_MSG_CHECKING([option: background post enabled])
-AC_ARG_ENABLE(background-post, AC_HELP_STRING([--disable-background-post],[Disable background posting]))
+AC_ARG_ENABLE(background-post, AS_HELP_STRING([--disable-background-post],[Disable background posting]))
if test x$enable_background_post != "xno" ; then
AC_DEFINE([BACKGROUND_POST], [], [Enable background posting support])
AC_MSG_RESULT([yes])
@@ -248,7 +248,7 @@ fi
dnl enable keyboard locking support
AC_MSG_CHECKING([option: keyboard lock enabled])
-AC_ARG_ENABLE(keyboard-lock, AC_HELP_STRING([--disable-keyboard-lock],[Disable keyboard locking]))
+AC_ARG_ENABLE(keyboard-lock, AS_HELP_STRING([--disable-keyboard-lock],[Disable keyboard locking]))
if test x$enable_keyboard_lock != "xno" ; then
AC_DEFINE([KEYBOARD_LOCK], [], [Enable keyboard lock support])
AC_MSG_RESULT([yes])
@@ -258,7 +258,7 @@ fi
dnl enable from encoding support
AC_MSG_CHECKING([option: from encoding enabled])
-AC_ARG_ENABLE(from-encoding, AC_HELP_STRING([--enable-from-encoding],[Enable From encoding in sent messages]))
+AC_ARG_ENABLE(from-encoding, AS_HELP_STRING([--enable-from-encoding],[Enable From encoding in sent messages]))
if test x$enable_from_encoding = "xyes" ; then
AC_DEFINE([ENCODE_FROMS], [], [Enable From address encoding in sent messages])
AC_MSG_RESULT([yes])
@@ -269,7 +269,7 @@ fi
dnl OPTION: name of local submission agent
dnl Might not be sendmail, but it MUST speak SMTP on stdin/stdout
AC_ARG_WITH(smtp-msa,
- AC_HELP_STRING([--with-smtp-msa=PATH],[Local Mail Submission Agent (sendmail)]),
+ AS_HELP_STRING([--with-smtp-msa=PATH],[Local Mail Submission Agent (sendmail)]),
[
case "$withval" in
no)
@@ -292,7 +292,7 @@ fi
dnl OPTION: local msa arguments
smtp_msa_flags="-bs -odb -oem"
AC_ARG_WITH(smtp-msa-flags,
- AC_HELP_STRING([--with-smtp-msa-flags=FLAGS],[MSA flags for SMTP on stdin/stdout (-bs -odb -oem)]),
+ AS_HELP_STRING([--with-smtp-msa-flags=FLAGS],[MSA flags for SMTP on stdin/stdout (-bs -odb -oem)]),
[
if test "x$withval" != "xno" ; then
smtp_msa_flags=$withval
@@ -303,7 +303,7 @@ AC_DEFINE_UNQUOTED([SENDMAILFLAGS], "$smtp_msa_flags", [Local MSA flags for SMTP
dnl OPTION: name of local news posting agent and flags
npa="inews"
AC_ARG_WITH(npa,
- AC_HELP_STRING([--with-npa=PATH],[Posting agent when no nntp-servers defined (inews)]),
+ AS_HELP_STRING([--with-npa=PATH],[Posting agent when no nntp-servers defined (inews)]),
[
case "$withval" in
no)
@@ -322,7 +322,7 @@ AC_ARG_WITH(npa,
npa_flags="-h"
AC_ARG_WITH(npa-flags,
- AC_HELP_STRING([--with-npa-flags=FLAGS],[Flags to allow posting via local agent (-h)]),
+ AS_HELP_STRING([--with-npa-flags=FLAGS],[Flags to allow posting via local agent (-h)]),
[
if test "x$withval" != "xno" ; then
npa_flags=$withval
@@ -334,7 +334,7 @@ fi
dnl OPTION: password changing program
AC_ARG_WITH(password-prog,
- AC_HELP_STRING([--with-password-prog=PATH],[Password change program (/bin/passwd)]),
+ AS_HELP_STRING([--with-password-prog=PATH],[Password change program (/bin/passwd)]),
[
case "$withval" in
no)
@@ -356,7 +356,7 @@ fi
dnl OPTION: basic spell checking program
AC_ARG_WITH(simple-spellcheck,
- AC_HELP_STRING([--with-simple-spellcheck=PROG],[Spellcheck program reads stdin, emits misspellings on stdout]),
+ AS_HELP_STRING([--with-simple-spellcheck=PROG],[Spellcheck program reads stdin, emits misspellings on stdout]),
[
if test "x$withval" != "xno" ; then
SPELLPROG=$withval
@@ -396,7 +396,7 @@ fi
dnl OPTION: interactive spell checking program
AC_ARG_WITH(interactive-spellcheck,
- AC_HELP_STRING([--with-interactive-spellcheck=PROG],[Interactive, filewise spell checker]),
+ AS_HELP_STRING([--with-interactive-spellcheck=PROG],[Interactive, filewise spell checker]),
[
if test "x$withval" != "xno" ; then
ISPELLPROG=$withval
@@ -443,7 +443,7 @@ case "$prefix" in
*) dpv=${prefix}/lib/pine.conf ;;
esac
AC_ARG_WITH(system-pinerc,
- AC_HELP_STRING([--with-system-pinerc=VALUE], [System pinerc (/usr/local/lib/pine.conf)]),
+ AS_HELP_STRING([--with-system-pinerc=VALUE],[System pinerc (/usr/local/lib/pine.conf)]),
[
case "$withval" in
no)
@@ -466,7 +466,7 @@ case "$prefix" in
*) dpv=${prefix}/lib/pine.conf.fixed ;;
esac
AC_ARG_WITH(system-fixed-pinerc,
- AC_HELP_STRING([--with-system-fixed-pinerc=VALUE], [System fixed pinerc (/usr/local/lib/pine.conf.fixed)]),
+ AS_HELP_STRING([--with-system-fixed-pinerc=VALUE],[System fixed pinerc (/usr/local/lib/pine.conf.fixed)]),
[
case "$withval" in
no)
@@ -490,7 +490,7 @@ case "$prefix" in
*) dpv=${prefix}/lib/pine.info ;;
esac
AC_ARG_WITH(local-support-info,
- AC_HELP_STRING([--with-local-support-info=VALUE], [Local Support Info File (/usr/local/lib/pine.info)]),
+ AS_HELP_STRING([--with-local-support-info=VALUE],[Local Support Info File (/usr/local/lib/pine.info)]),
[
case "$withval" in
no)
@@ -510,7 +510,7 @@ AC_DEFUN([PINEVAR],
[
dpv=$3
AC_ARG_WITH($1,
- AC_HELP_STRING(--with-$1=VALUE, [$4 ($3)]),
+ AS_HELP_STRING([--with-$1=VALUE],[$4 ($3)]),
[
if test "x$withval" != "xno" ; then
dpv=$withval
@@ -525,7 +525,7 @@ AC_DEFUN([PINEVAR_UNQUOTED],
[
dpv=$3
AC_ARG_WITH($1,
- AC_HELP_STRING(--with-$1=VALUE, [$4 ($3)]),
+ AS_HELP_STRING([--with-$1=VALUE],[$4 ($3)]),
[
if test "x$withval" != "xno" ; then
dpv=$withval
@@ -583,7 +583,7 @@ PINEVAR_UNQUOTED(default-printer, DF_DEFAULT_PRINTER, [ANSI_PRINTER], [Default p
dnl set PASSFILE?
AC_ARG_WITH(passfile,
- AC_HELP_STRING([--with-passfile=FILENAME],[Password cache file (NOT secure, NOT recommended)]),
+ AS_HELP_STRING([--with-passfile=FILENAME],[Password cache file (NOT secure, NOT recommended)]),
[
case "$withval" in
no)
@@ -598,14 +598,14 @@ AC_ARG_WITH(passfile,
dnl os-specific credential cache?
AC_ARG_WITH(local-password-cache,
- AC_HELP_STRING([--without-local-password-cache],[Disable OS-specific password cache, if supported]),
+ AS_HELP_STRING([--without-local-password-cache],[Disable OS-specific password cache, if supported]),
[
alpine_os_credential_cache=$withval
])
dnl Particular os-specific credential cache?
AC_ARG_WITH(local-password-cache-method,
- AC_HELP_STRING([--with-local-password-cache-method],[OS-specific credential cache (OSX=APPLEKEYCHAIN, Windows=WINCRED)]),
+ AS_HELP_STRING([--with-local-password-cache-method],[OS-specific credential cache (OSX=APPLEKEYCHAIN, Windows=WINCRED)]),
[
alpine_os_credential_cache_method=$withval
])
@@ -624,7 +624,7 @@ fi
dnl set DF_SSHPATH?
AC_ARG_WITH(default-sshpath,
- AC_HELP_STRING([--with-default-sshpath=FILENAME],[set default value of ssh command path (defining should cause ssh to be preferred to rsh)]),
+ AS_HELP_STRING([--with-default-sshpath=FILENAME],[set default value of ssh command path (defining should cause ssh to be preferred to rsh)]),
[
case "$withval" in
no)
@@ -639,7 +639,7 @@ AC_ARG_WITH(default-sshpath,
dnl set DF_SSHCMD?
AC_ARG_WITH(default-sshcmd,
- AC_HELP_STRING([--with-default-sshcmd=PERCENT_S_STRING],[set default value of ssh command string (usually "%s %s -l %s exec /etc/r%sd")]),
+ AS_HELP_STRING([--with-default-sshcmd=PERCENT_S_STRING],[set default value of ssh command string (usually "%s %s -l %s exec /etc/r%sd")]),
[
case "$withval" in
no)
@@ -655,7 +655,7 @@ AC_ARG_WITH(default-sshcmd,
dnl Include SSL?
dnl Set SSLDIR for c-client make
AC_ARG_WITH(ssl,
- AC_HELP_STRING([--without-ssl],[Disable SSL support (OpenSSL)]),
+ AS_HELP_STRING([--without-ssl],[Disable SSL support (OpenSSL)]),
[ with_ssl=$withval ])
if test "x$with_ssl" = "xno" ; then
@@ -718,7 +718,7 @@ else
esac
AC_ARG_WITH(ssl-dir,
- AC_HELP_STRING([--with-ssl-dir=DIR], [Root of SSL lib/include path]),
+ AS_HELP_STRING([--with-ssl-dir=DIR],[Root of SSL lib/include path]),
[
if test "x$withval" != "xno" ; then
alpine_SSLDIR=$withval
@@ -726,7 +726,7 @@ else
])
AC_ARG_WITH(ssl-certs-dir,
- AC_HELP_STRING([--with-ssl-certs-dir=DIR], [Path to SSL certificate directory]),
+ AS_HELP_STRING([--with-ssl-certs-dir=DIR],[Path to SSL certificate directory]),
[
if test "x$withval" != "xno" ; then
alpine_SSLCERTS=$withval
@@ -734,7 +734,7 @@ else
])
AC_ARG_WITH(ssl-include-dir,
- AC_HELP_STRING([--with-ssl-include-dir=DIR], [SSL include file path]),
+ AS_HELP_STRING([--with-ssl-include-dir=DIR],[SSL include file path]),
[
if test "x$withval" != "xno" ; then
alpine_SSLINCLUDE=$withval
@@ -742,7 +742,7 @@ else
])
AC_ARG_WITH(ssl-lib-dir,
- AC_HELP_STRING([--with-ssl-lib-dir=DIR], [SSL library path]),
+ AS_HELP_STRING([--with-ssl-lib-dir=DIR],[SSL library path]),
[
if test "x$withval" != "xno" ; then
alpine_SSLLIB=$withval
@@ -764,7 +764,7 @@ fi
dnl Include Kerberos?
dnl Set GSSDIR for c-client make
AC_ARG_WITH(krb5,
- AC_HELP_STRING([--without-krb5],[Disable Kerberos support]),
+ AS_HELP_STRING([--without-krb5],[Disable Kerberos support]),
[ with_krb5=$withval ])
if test "x$with_krb5" = "xno" ; then
@@ -773,7 +773,7 @@ else
alpine_GSSTYPE=
AC_ARG_WITH(krb5-dir,
- AC_HELP_STRING([--with-krb5-dir=DIR], [Root of Kerberos lib/include path]),
+ AS_HELP_STRING([--with-krb5-dir=DIR],[Root of Kerberos lib/include path]),
[
if test "x$withval" != "xno" ; then
CPPFLAGS="$CPPFLAGS -I${withval}/include"
@@ -782,7 +782,7 @@ else
])
AC_ARG_WITH(krb5-include-dir,
- AC_HELP_STRING([--with-krb5-include-dir=DIR], [Kerberos include file path]),
+ AS_HELP_STRING([--with-krb5-include-dir=DIR],[Kerberos include file path]),
[
if test "x$withval" != "xno" ; then
CPPFLAGS="$CPPFLAGS -I$withval"
@@ -790,7 +790,7 @@ else
])
AC_ARG_WITH(krb5-lib-dir,
- AC_HELP_STRING([--with-krb5-lib-dir=DIR], [Kerberos library path]),
+ AS_HELP_STRING([--with-krb5-lib-dir=DIR],[Kerberos library path]),
[
if test "x$withval" != "xno" ; then
LDFLAGS="$LDFLAGS -L$withval"
@@ -800,7 +800,7 @@ fi
dnl Include LDAP?
AC_ARG_WITH(ldap,
- AC_HELP_STRING([--without-ldap],[Disable LDAP query support]),
+ AS_HELP_STRING([--without-ldap],[Disable LDAP query support]),
[ with_ldap=$withval ])
if test "x$with_ldap" = "xno" ; then
@@ -811,7 +811,7 @@ else
alpine_with_ldap=yes
AC_ARG_WITH(ldap-dir,
- AC_HELP_STRING([--with-ldap-dir=DIR], [Root of LDAP lib/include path]),
+ AS_HELP_STRING([--with-ldap-dir=DIR],[Root of LDAP lib/include path]),
[
if test "x$withval" != "xno" ; then
CPPFLAGS="$CPPFLAGS -I${withval}/include"
@@ -820,7 +820,7 @@ else
])
AC_ARG_WITH(ldap-include-dir,
- AC_HELP_STRING([--with-ldap-include-dir=DIR], [Directory containing LDAP include files]),
+ AS_HELP_STRING([--with-ldap-include-dir=DIR],[Directory containing LDAP include files]),
[
if test "x$withval" != "xno" ; then
CPPFLAGS="$CPPFLAGS -I$withval"
@@ -828,7 +828,7 @@ else
])
AC_ARG_WITH(ldap-lib-dir,
- AC_HELP_STRING([--with-ldap-lib-dir=DIR], [LDAP library path]),
+ AS_HELP_STRING([--with-ldap-lib-dir=DIR],[LDAP library path]),
[
if test "x$withval" != "xno" ; then
LDFLAGS="$LDFLAGS -L$withval"
@@ -838,12 +838,12 @@ fi
dnl Include SMIME?
AC_ARG_WITH(smime,
- AC_HELP_STRING([--without-smime],[Disable S/MIME]),
+ AS_HELP_STRING([--without-smime],[Disable S/MIME]),
[ with_smime=$withval ])
dnl Include TCL?
AC_ARG_WITH(tcl,
- AC_HELP_STRING([--without-tcl],[Disable TCL, thus Web Alpine support]),
+ AS_HELP_STRING([--without-tcl],[Disable TCL, thus Web Alpine support]),
[ with_tcl=$withval ])
if test "x$with_tcl" = "xno" ; then
@@ -851,14 +851,14 @@ if test "x$with_tcl" = "xno" ; then
AC_MSG_NOTICE([Excluding TCL Support, and thus Web Alpine Support])
else
AC_ARG_WITH(tcl-lib,
- AC_HELP_STRING([--with-tcl-lib=LIBRARY], [Specific TCL Library, like \"tcl8.5\"]),
+ AS_HELP_STRING([--with-tcl-lib=LIBRARY],[Specific TCL Library, like \"tcl8.5\"]),
[
if test "x$withval" != "xno" ; then
alpine_TCLLIB=$withval
fi
])
AC_ARG_WITH(tcl-include,
- AC_HELP_STRING([--with-tcl-include=DIR], [Directory containing TCL include files]),
+ AS_HELP_STRING([--with-tcl-include=DIR],[Directory containing TCL include files]),
[
if test "x$withval" != "xno" ; then
CPPFLAGS="$CPPFLAGS -I$withval"
@@ -868,15 +868,15 @@ else
fi
AC_ARG_WITH(supplied-regex,
- AC_HELP_STRING([--with-supplied-regex],[Use regex library supplied with alpine]),
+ AS_HELP_STRING([--with-supplied-regex],[Use regex library supplied with alpine]),
[ alpine_REGEX=$withval ])
AC_ARG_WITH(pthread,
- AC_HELP_STRING([--without-pthread],[Do NOT test for nor build with POSIX thread support]),
+ AS_HELP_STRING([--without-pthread],[Do NOT test for nor build with POSIX thread support]),
[ with_pthread=$withval ])
AC_ARG_WITH(system-mail-directory,
- AC_HELP_STRING([--with-system-mail-directory=DIR], [Directory where local mail is delivered]),
+ AS_HELP_STRING([--with-system-mail-directory=DIR],[Directory where local mail is delivered]),
[
if test "x$withval" != "xno" ; then
alpine_with_local_maildir="$withval"
@@ -884,7 +884,7 @@ AC_ARG_WITH(system-mail-directory,
])
AC_ARG_WITH(c-client-target,
- AC_HELP_STRING([--with-c-client-target=TARGET], [IMAP build target (see imap/Makefile)]),
+ AS_HELP_STRING([--with-c-client-target=TARGET],[IMAP build target (see imap/Makefile)]),
[
if test "x$withval" != "xno" ;then
alpine_with_c_client_target="$withval"
@@ -894,7 +894,7 @@ AC_ARG_WITH(c-client-target,
dnl Without IPv6?
AC_ARG_WITH(ipv6,
- AC_HELP_STRING([--without-ipv6],[Disable IPv6, primarily to work around resolver problems]),
+ AS_HELP_STRING([--without-ipv6],[Disable IPv6, primarily to work around resolver problems]),
[ with_ipv6=$withval ])
if test "x$with_ipv6" = "xno" ; then
@@ -917,7 +917,7 @@ if test x$enable_dmalloc = "xyes" ; then
AC_CHECK_LIB($dmalloc_lib,dmalloc_shutdown,,
[
- AC_ERROR([$dmalloc_lib requested, but -ldmalloc not found])
+ AC_MSG_ERROR($dmalloc_lib requested, but -ldmalloc not found)
])
fi
@@ -952,7 +952,7 @@ AC_CHECK_LIB(tinfo, setupterm,
LIBS="$LIBS -ltermcap"
],
[
- AC_ERROR([Terminfo/termcap not found])
+ AC_MSG_ERROR(Terminfo/termcap not found)
])
])
])
@@ -1050,7 +1050,7 @@ if test "x$alpine_SSLTYPE" != "xnone" ; then
alpine_CRYPTO = "none"
])
if test "x$alpine_CRYPTO" = "xnone" ; then
- AC_ERROR([crypto library NOT found])
+ AC_MSG_ERROR(crypto library NOT found)
else
AC_MSG_NOTICE([crypto library found])
fi
@@ -1072,7 +1072,7 @@ if test "x$alpine_PAM" != "xnone" ; then
alpine_pam_none_reason="library files not found"
])
if test -n "$alpine_pam_none_reason" ; then
- AC_ERROR([No PAM support: $alpine_pam_none_reason])
+ AC_MSG_ERROR(No PAM support: $alpine_pam_none_reason)
fi
fi
@@ -1138,7 +1138,7 @@ if test x$alpine_REGEX != "xyes" ; then
AC_SEARCH_LIBS([regcomp],posix regexp regex re,,
[
if test x$alpine_REGEX = "xno" ; then
- AC_ERROR([Unable to find system regex library])
+ AC_MSG_ERROR(Unable to find system regex library)
else
alpine_REGEX=yes
fi
@@ -1148,7 +1148,7 @@ if test x$alpine_REGEX != "xyes" ; then
AC_CHECK_HEADER([regex.h],,
[
if test x$alpine_REGEX = "xno" ; then
- AC_ERROR([Unable to find system regex include file])
+ AC_MSG_ERROR(Unable to find system regex include file)
else
alpine_REGEX=yes
fi
@@ -1198,7 +1198,7 @@ AC_HEADER_SYS_WAIT
AC_HEADER_TIME
AC_HEADER_TIOCGWINSZ
-AC_UNISTD_H
+AC_CHECK_HEADERS([unistd.h])
AC_CHECK_HEADERS([errno.h \
ctype.h \
@@ -1235,7 +1235,7 @@ AC_CHECK_HEADER([termios.h],
AC_CHECK_HEADER([sgtty.h],
AC_DEFINE(HAS_SGTTY, [1], [Define if systems uses old BSD-style terminal control]),
[
- AC_ERROR([Unable to figure out terminal control method])
+ AC_MSG_ERROR(Unable to figure out terminal control method)
])
])
])
@@ -1243,7 +1243,18 @@ AC_CHECK_HEADER([termios.h],
dnl CHECK TYPEDEFS
-AC_TYPE_SIGNAL
+AC_DIAGNOSE([obsolete],[your code may safely assume C89 semantics that RETSIGTYPE is void.
+Remove this warning and the `AC_CACHE_CHECK' when you adjust the code.])dnl
+AC_CACHE_CHECK([return type of signal handlers],[ac_cv_type_signal],[AC_COMPILE_IFELSE(
+[AC_LANG_PROGRAM([#include <sys/types.h>
+#include <signal.h>
+],
+ [return *(signal (0, 0)) (0) == 1;])],
+ [ac_cv_type_signal=int],
+ [ac_cv_type_signal=void])])
+AC_DEFINE_UNQUOTED([RETSIGTYPE],[$ac_cv_type_signal],[Define as the return type of signal handlers
+ (`int' or `void').])
+
AC_TYPE_SIZE_T
AC_TYPE_MODE_T
AC_TYPE_PID_T
@@ -1263,7 +1274,7 @@ AC_CHECK_HEADERS([stdint.h], [uint16=uint16_t], [
if $ac_cv_sizeof_unsigned_int -eq 2 ; then
uint16="unsigned int"
else
- AC_ERROR([Unable to determine 16 bit integer type])
+ AC_MSG_ERROR(Unable to determine 16 bit integer type)
fi
fi
])
@@ -1282,7 +1293,7 @@ AC_CHECK_HEADERS([stdint.h], [uint32=uint32_t], [
if $ac_cv_sizeof_unsigned_long -eq 4 ; then
uint32="unsigned long"
else
- AC_ERROR([Unable to determine 32 bit integer type])
+ AC_MSG_ERROR(Unable to determine 32 bit integer type)
fi
fi
])
@@ -1292,7 +1303,7 @@ AC_DEFINE_UNQUOTED([UINT32], $uint32, [System defined unsigned 32 bit integer])
AC_CACHE_CHECK(argument pointer type of qsort compare function and base,
ac_cv_func_qsort_argtype,
-[AC_TRY_COMPILE([
+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#if HAVE_STDLIB_H
#include "stdlib.h"
#endif
@@ -1302,10 +1313,9 @@ extern sortf(const void *, const void *);
int sortf(a, b)
const void *a;
const void *b; { return 0; }
-],[
+]], [[
qsort(base, 2, sizeof(char *), sortf);
-],
- ac_cv_func_qsort_argtype=void, ac_cv_func_qsort_argtype=char)
+]])],[ac_cv_func_qsort_argtype=void],[ac_cv_func_qsort_argtype=char])
])
AC_DEFINE_UNQUOTED([qsort_t], $ac_cv_func_qsort_argtype, [qsort compare function argument type])
@@ -1571,7 +1581,7 @@ case "$host" in
AC_DEFINE([_WINDOWS], [1], [Windows is just too different])
;;
*)
- AC_ERROR([Unrecognized system: $host])
+ AC_MSG_ERROR(Unrecognized system: $host)
;;
esac
@@ -1722,10 +1732,11 @@ AC_SUBST([WEB_PUBCOOKIE_LINK])
AC_SUBST([AM_CFLAGS])
AC_SUBST([AM_LDFLAGS])
-AC_OUTPUT(m4/Makefile po/Makefile.in regex/Makefile \
+AC_CONFIG_FILES([m4/Makefile po/Makefile.in regex/Makefile \
pith/osdep/Makefile pith/charconv/Makefile pith/Makefile \
pico/osdep/Makefile pico/Makefile \
alpine/osdep/Makefile alpine/Makefile \
web/src/Makefile web/src/pubcookie/Makefile \
web/src/alpined.d/Makefile \
- Makefile)
+ Makefile])
+AC_OUTPUT