summaryrefslogtreecommitdiff
path: root/web/src/pubcookie/Makefile.am
diff options
context:
space:
mode:
authorEduardo Chappa <echappa@gmx.com>2013-02-03 00:59:38 -0700
committerEduardo Chappa <echappa@gmx.com>2013-02-03 00:59:38 -0700
commit094ca96844842928810f14844413109fc6cdd890 (patch)
treee60efbb980f38ba9308ccb4fb2b77b87bbc115f3 /web/src/pubcookie/Makefile.am
downloadalpine-094ca96844842928810f14844413109fc6cdd890.tar.xz
Initial Alpine Version
Diffstat (limited to 'web/src/pubcookie/Makefile.am')
-rw-r--r--web/src/pubcookie/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/web/src/pubcookie/Makefile.am b/web/src/pubcookie/Makefile.am
new file mode 100644
index 00000000..e4da1c39
--- /dev/null
+++ b/web/src/pubcookie/Makefile.am
@@ -0,0 +1,37 @@
+## Process this file with automake to produce Makefile.in
+## Use aclocal -I m4; automake
+
+# ========================================================================
+# Copyright 2006-2008 University of Washington
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# ========================================================================
+
+
+WP_UIDMAPPER_SOCKET = "/tmp/wp_uidmapper"
+WEBSERVER_UID = 65534
+
+CFLAGS = '-DWP_UIDMAPPER_SOCKET=$(WP_UIDMAPPER_SOCKET)' \
+ '-DWEBSERVER_UID=$(WEBSERVER_UID)' \
+ '-DAUTH_GSS_PROXY_PATH="$(WEB_BINDIR)/wp_gssapi_proxy"'
+
+bin_PROGRAMS = wp_uidmapper wp_tclsh wp_gssapi_proxy wp_umc
+
+noinst_LIBRARIES = libauthgssproxy.a
+
+libauthgssproxy_a_SOURCES = auth_gss_proxy.c
+
+wp_uidmapper_SOURCES = wp_uidmapper.c id_table.c id_table.h
+
+wp_tclsh_SOURCES = wp_tclsh.c wp_uidmapper_lib.c
+
+wp_gssapi_proxy_SOURCES = wp_gssapi_proxy.c wp_uidmapper_lib.c
+
+wp_umc_SOURCES = wp_umc.c wp_uidmapper_lib.c
+
+AM_CPPFLAGS = -I@top_builddir@/include -I@top_srcdir@/include