summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEduardo Chappa <chappa@washington.edu>2013-07-10 23:11:24 -0600
committerEduardo Chappa <chappa@washington.edu>2013-07-10 23:11:24 -0600
commitb0f119565dcf76eb0ef8926e84736ea532aefdb1 (patch)
tree427137d81303896a5679db9f664a802c4c0f40a8 /configure.ac
parentcd0c8df49a052009fd0e0a5141632333ede80dd3 (diff)
downloadalpine-b0f119565dcf76eb0ef8926e84736ea532aefdb1.tar.xz
* Change to configure to not to build Web Alpine if tcl.h is not found by the
configure script.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 52e2b7f9..9a6c230b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1119,7 +1119,7 @@ if test -n "$WEB_BUILD" ; then
else
AC_CHECK_HEADER(tcl.h,,
[
- for dir in tcl8.4 tcl8.3 tcl84 tcl83 ; do
+ for dir in tcl8.5 tcl8.4 tcl8.3 tcl84 tcl83 ; do
AC_CHECK_FILE([/usr/include/$dir/tcl.h],
[
found=yes
@@ -1129,6 +1129,10 @@ if test -n "$WEB_BUILD" ; then
break
fi
done
+ if test "$found" != "yes" ; then
+ WEB_BUILD=
+ AC_MSG_NOTICE([header file tcl.h NOT found: Web Alpine will not be built])
+ fi
])
fi
fi